Cesium > Nouvelle version v1.2.9


#21

Je glisse juste un petit message de soutiens à @kimamila et autres contributeurs au code, c’est magique tout ce taf de correction de bug et évolutions!! :star_struck::heavy_heart_exclamation:


#22

ok, j’ai trouvé le soucis pour la version Windows de Cesium. Une librairie base58 quia changé de signature dans les dernière versions.

J’en ai profité pour migrer Cesium-desktop sur NW.js en version 0.35.3. Et ajouter une option --debug quand on lance Cesium, pour avoir les traces dans le terminal.

Ce sera une version v1.3.x. Je suis en train de tester


#23

Petit retour sur la 1.3.0 sous Xubuntu

J’ai une fenêtre pop-up qui s’ouvre avec rien dedans :

Et voici la trace :

cesium --debug
[9468:9468:0102/162029.421219:ERROR:sandbox_linux.cc(366)] InitializeSandbox() called with multiple threads in process gpu-process.
[9446:9446:0102/162029.666732:ERROR:gpu_process_transport_factory.cc(967)] Lost UI shared context.
[9446:9446:0102/162029.677761:ERROR:x11_input_method_context_impl_gtk.cc(144)] Not implemented reached in virtual void libgtkui::X11InputMethodContextImplGtk::SetSurroundingText(const base::string16 &, const gfx::Range &)
[9446:9446:0102/162031.608780:ERROR:CONSOLE(1)] "Uncaught ReferenceError: DevToolsAPI is not defined", source: chrome-devtools://devtools/bundled/devtools_app.html?remoteBase=https://chrome-devtools-frontend.appspot.com/serve_file/@ac9418ba9c3bd7f6baaffa0b055dfe147e0f8364/&dockSide=undocked (1)
[9446:9446:0102/162031.614854:ERROR:CONSOLE(1)] "Uncaught ReferenceError: DevToolsAPI is not defined", source: chrome-devtools://devtools/bundled/devtools_app.html?remoteBase=https://chrome-devtools-frontend.appspot.com/serve_file/@ac9418ba9c3bd7f6baaffa0b055dfe147e0f8364/&dockSide=undocked (1)

#24

Ce n’est pas un version stable.

Oui, je voulais ouvrir la console JS, mais du coup il me faut intégrer une version SDK de NW.js (qui intègre Chromium) et c’est trop lourd.
J’ai changé mon fusil d’épaule, dans la v1.3.1, en activant des logs dans le terminal uniquement…


#25

j’en suis bien conscient, c’est pour ça que test :wink:


#26

Hello, j’ai le même pb que @Greg , au lancement se fige sur “bienvenue”, grosse utilisation du proc, puis plantage “Désolé, le programme « nw » a quitté de façon inattendue”.
Je suis sur la 1.2.6 mais ça me faisais déjà ça sous la précédente, j’vais essayer d’install la 1.2.9 mais j’ai peur que se soit pareil… T’as trouvé se que c’était chez toi @Greg?


#27

Moi en fait j’avais plusieurs bug et j’ai fait une réinstalle Xubuntu complète, mais j’imagine qu’il doit y a voir plus simple…!!


#28

Je reviens avec mon pb, toujours pareil avec la 1.2.9, j’imagine qu’il y a un fichier config qui ne se supprime pas a la désinstallation et donc recréait le problème même sur une nouvelle installation. Comment puis je résoure ça svp?


#29

Hum, si tu veux supprimer tous les fichiers de conf liés à un paquet (ici cesium), il faut “purger”. Au lieu de faire sudo aptitude remove cesium, tu fais sudo aptitude purge cesium . Idem si tu utilises apt-get .

Pas certain que ça résolve ton problème, cependant. Mais ça vaut le coup d’essayer.

edit - je suppose que ton ordi tourne avec GNU/Linux. Je ne suis pas compétent sur les autres systèmes. Au pire, tu peux utiliser la version .zip, comme expliqué dans ce tuto.


#30

Je lis ça peut être un peu tard…

J’avais pensé à ça aussi…

Je ne crois pas que cela avais marché chez moi non plus…

Peut être qu’il y moyen d’aller le chercher et le supprimer sois même ce fichier de config. @kimamila…??


#31

@Greg @matograine
Non ça n’a pas fonctionné, le pire c’est que j’anime un apéro monnaie libre/install party dans 30min sans pouvoir leur montrer Césium Desktop, le comble!


#32

heu, question con, si tu ouvres une session “invité” à la connexion sur ton ordi ça le ferais pas?


#33

hey sympa la petite caravane!!


#34

Ha ça y est,en virant tout les fichiers à la mano j’ai enfin retrouvé un Césium Desktop qui fonctionne! :yum:
Et j’ai changé de noeud sans pb cette fois! Merci beaucoup pour votre aide :wink: @matograine @Greg


#35

Comme je dis maintenant : si cette aide t’a été utile, tu peux un don aux développeurs ou à la rémunération des noeuds :wink: (c’est vrai aussi si l’aide était inutile, d’ailleurs :lol:)

clefs :
Remuniter : TENGx7WtzFsTXwnbrPEvb6odX2WnqYcnnrjiiLvp1mS
Devs : 78ZwwgpgdH5uLZLbThUQH7LKwPgjMunYfLiCfUCySkM8

Bravo, en tout cas !