Compilation de Duniter sous Debian 10

Sous Debian 10 architecture aarch64, après avoir suivi le tutoriel de compilation d’après les sources, je tombe sur le message :

yarn install v1.17.3
warning npm-shrinkwrap.json found. This will not be updated or respected. See https://yarnpkg.com/en/docs/migrating-from-npm for more information.
[1/5] Validating package.json...
error duniter@1.7.19: The engine "node" is incompatible with this module. Expected version ">=8.2.1 <10". Got "10.15.2"
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Il semble que le fichier npm-shrinkwrap.json ne soit plus adapté. Je ne comprends pas grand chose à la compilation avec les outils (node/npm/yarn).

J’ai créé une issue sur GitLab : https://git.duniter.org/nodes/typescript/duniter/issues/1386

Tu as essayé sur la branche dev qui gère NodeJs v10 ?

Non, j’ai juste essayé la dernière stable. Je suis en train de compiler dev. […] Ça plante avec :

error /home/hugo/duniter/duniter_dev_67528e/node_modules/leveldown: Command failed.
Exit code: 127
Command: prebuild-install || node-gyp rebuild
Arguments: 
Directory: /home/hugo/duniter/duniter_dev_67528e/node_modules/leveldown
Output:

leveldown n’a pas pu être compilé sur ton processeur aarch64.

Possible que l’installation avec leveldown en v5 (Changelog) fonctionne, car elle inclut le binaire.
Par contre, pas sûr que Duniter continue de fonctionner correctement avec cette nouvelle version, car l’API a changée. Tu peux essayer à tes risques et périls.

yarn upgrade leveldown

Je viens de tester, ça fonctionne pour l’instant de mon côté. Pas sûr, que ça soit le bon plan.

1 J'aime