Liste des transactions d'un noeud

Bonjour,

J’ai activé BMA sur un de mes noeuds pour faire des requêtes via l’API HTTP.

Je pense que cela fonctionne puisque j’ai cela :

}51 [12:20:44] ben@pc-96: ~ $ curl -XGET http://185.193.38.231:21629/node/summary
{
“duniter”: {
“software”: “duniter”,
“version”: “1.7.11”,
“forkWindowSize”: 100
}

Mais quand j’exécute la requête : }52 [12:20:53] ben@pc-96: ~ $ curl -XGET http://185.193.38.231:21629/tx/history/6sn1FAwcURiAY1L86EKBtobFiYq3uxcrPUazYQ2ZLShK

J’ai cela :

{
“currency”: “g1”,
“pubkey”: “6sn1FAwcURiAY1L86EKBtobFiYq3uxcrPUazYQ2ZLShK”,
“history”: {
“sending”: ,
“received”: ,
“receiving”: ,
“sent”: ,
“pending”:
}

Du coup il ne me montre aucune transaction, quelqu’un sait si j’ai loupé quelque chose ?

J’ai essayé de démarrer mon noeud duniter comme suivant :
sudo -u duniter duniter webstart --webmhost 185.193.38.231 --webmport 10901 --bma --store-txs -p 21629

mais le résultat est le même.

Cette option doit être activée avant de synchroniser (l’indexation des transactions se produit à mesure que les blocs sont enregistrés), puis plus besoin de la réactiver ensuite car elle est sauvegardée.

Donc, là, il te suffit de resynchroniser.

1 J'aime

Ok merci @cgeek :slight_smile:

Cela fonctionne, j’ai synchronisé de nouveau et j’ai la liste des transactions.

3 J'aimes