Unable to sign in in git.duniter.org using my github account

Hi. I am unable to get logged in in the gitlab instace when trying to use my github account through oauth. I authorized the access, but I get a 402 error, and then:

Could not authenticate you from GitHub because “Csrf detected”

Any thoughts or suggestions how to solve this?

PS. I used two-factor authentication in github.com.

Hi @Santiago,

Are you willing to do this ?
https://docs.gitlab.com/ee/integration/github.html

I’m not an expert, but looks like an exception case.

Best,

No, that is actually the configuration that git.duniter.org admins should have done.

As user, I had already authorized git.duniter.org to use my github credentials. Tyring again, I just got this:

422
The change you requested was rejected.

Make sure you have access to the thing you tried to change.

Please contact your GitLab administrator if you think this is a mistake.

cc @florck , @1000i100 our gitlab admin :slight_smile:

Just to tell you I’ve seen your issue, but I don’t have the time to treat it. But you could help us by temporarily disabling the 2-factor authentication, just to verify if the problem comes from it.

thanks for the answer @cgeek, but disabling the two-factor authentication doesn’t change anything :frowning:

just tried with a clean browser session.

2 « J'aime »

Hi, thank-you for the report.
I will check this the next time i work on core gitlab stuff if nobody else have fixed it yet.

(I’m just back home from RML11)