[ANN] uCoin Apps > prototype v0.2

Hi All uCoiners !

You can test a preview version of uCoin Apps (v0.2) for Android :
https://play.google.com/store/apps/details?id=io.ucoin.ucoin

WARNING :
This version is a preview for developers only ! …the app is still very unstable, and a lot of functionnalities are not implemented yet : some buttons just do nothing.

HOW TO test :

  • Prequisite :
    • To be able to test a transfer, you must have a ucoin account (member or not), with some credit.
  • Install from your phone, using this link : https://play.google.com/store/apps/details?id=io.ucoin.ucoin
    (the application could not be found by a search, for now)
  • Fill the account data :
    • By default, you can use mine (but you we be enable to transfert or sign someone)
  • Fill node info (instead of my node, by default) :
    • node address : metab.ucoin.io
    • node port : 9201
  • What to test ?
    • From the home screen : try to search someone
    • From the search result, see it’s details and community
    • From a identity, try to sign and transfer

"That’s all ?!"
Yes, all other functionnalities are NOT ready to test yet. Be patient ! :wink:

HOW TO change the user account ?

For now, to be able to change the account settings (uid, salt and password), you need :

  • to uninstall uCoin Apps
  • then reinstall it.

HOW TO send my feedback ?

Open an issue here : https://github.com/ucoin-io/ucoin-android-app/issues

“Merci !”

5 « J'aime »

I forgot to thanks @smoul for his great help !

@smoul: don’t worry, i will add you as developper in the app’s details, on the play store :smile:

1 « J'aime »

Since I run on Firefox OS I won’t be able to give you that much feedback. I’ll try it on my old android phone (5 years old), still

EDIT : Well “this app is not compatible with your system” !

Hopefully I’m the only nerd there using a firefox os :wink:

1 « J'aime »

Hey @kimamila, thanks for releasing your app!

We have tried it this evening, but did not succeed in submitting an identity neither to certify someone (well … it says “succeed”, but we cannot find anything on ucoin servers).

Any idea of what is happening?

Btw: you should definitely remove your personal identifiers from the app :wink:

@cgeek thks to have test it ! :wink:

You could NOT create new identity for now. Have you try to connect with your personal account ?

To sign someone, you should : search (on top) -> click on a identity to open it -> then click on “sign” (on top).
I could see the request, when i do this on my node, but I will investigate anyway

Oh, creating a new identity is precisely what we wanted to do :confused: we will wait for your next version then!

I mean you can create it, but the “join” and “self” actions are disable… so u won’t be able to join

Well … dunno if I will be a nerd with my coming Ubuntu Phone :smile:

I have found ucoin app by searching in the play store !
It’s a great news, it is indexed ! :smile:

I have tried the app on my Galaxy Tab 4 Samsung Tablet :
I can log in and see the wallet, not much more. But I will investigate later, when the app will be more complete for the smart-phone…

On my android smart-phone, it works fine, except if I put french characters in the transaction comment… :wink:
But then, I get a clean error notification.

So it’s a successful test for me ! Bravo !

v0.3 preview : coming soon !

  • Could now add many wallets :

  • usable for new user : could now send a self certification and request membership :

  • Wallet’s credit auto-refresh :

2 « J'aime »

Nice !

Just one question… Why did you chose to not manage multiple wallets like in cutecoin ?

no, you will be able to add many wallets, not once. Of course, we need this to be able to have “home” wallet, wallets for compagnies,…

Yes but in cutecoin, wallets are just a salt derivated from the account salt… Here you are creating a unique salt / wallets.

I think we need to work on unification.

Salut les ucoiners

depuis j utilise ucoins apps sur mon samsung.

impossible d utiliser cutecoin sur mon ordinateur…

peut etre mon compte ne peut pas etre ouvert sur l ordi et sur le telephone en meme temps ?

Peux-tu nous donner plus de détails sur ce qu’il se passe exactement ?

quand je lance cutecoin 0.8.2 sur mon ordinateur
la fenetre s ouvre sur Loading account jeffrenchpilot
mais plus rien ne se passe comme bloquer…

Surement rien à voir avec la double application.

Pour en être certain, peux tu lancer cutecoin avec l’option “-d” (utilise cmd.exe pour le lancer) et peux tu placer le fichier “cutecoin.log” quelquepart et me l’envoyer ? Il est présent dans “C:\Users[ton compte]\AppData\Roaming\cutecoin”

il y a que cutecoin en fichier executable…
je ne trouve pas cmd.exe
j ai trouver cutecoin.log mais il est vide
desole mes connaissances informatique sont limiter
je vais apprendre les prochaines release peut etre ca remarchera

merci

Maj + clic sur le dossier contenant cutecoin.exe et entrer “cutecoin.exe -d”

Ca remplira le fichier cutecoin.log !