Appel à contributions pour Ğ1-Test

Merci Inso.

Ton nœud est là ! Par contre comme jellium, pour le moment je ne vois pas de blocs à vous dans la blockchain.

Ton nœud a-t-il l’air de calculer ?

Problème : après lecture des logs, j’ai :

  • En boucle (2 à 3 fois par seconde) :
2017-08-31T14:44:33+02:00 - info: GIVEN proof-of-work for block#44148 with 4 leading zeros followed by [0-9A-E]! stop PoW for 77mfxs
2017-08-31T14:44:33+02:00 - warn: The proof-of-work generation was canceled: Proof-of-work computation canceled because block received
2017-08-31T14:44:33+02:00 - info: Generating proof-of-work with 4 leading zeros followed by [0-9A-E]... (CPU usage set to 20%) for block#44148 77mfxs
2017-08-31T14:44:33+02:00 - info: Cancelling the work on PoW cluster
  • Entre-coupé de, par exemple :
2017-08-31T14:44:36+02:00 - info: GIVEN proof-of-work for block#44148 with 4 leading zeros followed by [0-9A-E]! stop PoW for 77mfxs
2017-08-31T14:44:36+02:00 - warn: The proof-of-work generation was canceled: Proof-of-work computation canceled because block received
2017-08-31T14:44:36+02:00 - warn: ETIMEDOUT
2017-08-31T14:44:36+02:00 - info: Peer 4XXUjytoubzg2Wkd9T6SsqSAWj8eWsxaSPEQtNh1ekzU unreachable: now considered as DOWN.
2017-08-31T14:44:36+02:00 - info: ⬇ PEER HYYsDawf
2017-08-31T14:44:36+02:00 - info: ⬇ PEER HYYsDawf
2017-08-31T14:44:36+02:00 - error:  httpCode=400, ucode=1015, message=Document already under treatment
2017-08-31T14:44:36+02:00 - info: ⬇ PEER HYYsDawf
2017-08-31T14:44:36+02:00 - error:  httpCode=400, ucode=1015, message=Document already under treatment
2017-08-31T14:44:36+02:00 - info: ⬇ PEER HYYsDawf
2017-08-31T14:44:36+02:00 - error:  httpCode=400, ucode=1015, message=Document already under treatment
2017-08-31T14:44:36+02:00 - info: ⬇ PEER HYYsDawf
2017-08-31T14:44:36+02:00 - error:  httpCode=400, ucode=1015, message=Document already under treatment
2017-08-31T14:44:37+02:00 - info: ⬇ PEER HYYsDawf
2017-08-31T14:44:37+02:00 - error:  httpCode=400, ucode=1015, message=Document already under treatment
2017-08-31T14:44:37+02:00 - info: ⬇ PEER HYYsDawf
2017-08-31T14:44:37+02:00 - error:  httpCode=400, ucode=1015, message=Document already under treatment
2017-08-31T14:44:37+02:00 - info: ⬇ PEER HYYsDawf
2017-08-31T14:44:37+02:00 - error:  httpCode=400, ucode=1015, message=Document already under treatment
2017-08-31T14:44:37+02:00 - info: GIVEN proof-of-work for block#44148 with 4 leading zeros followed by [0-9A-E]! stop PoW for 77mfxs
2017-08-31T14:44:37+02:00 - warn: The proof-of-work generation was canceled: Proof-of-work computation canceled because block received
2017-08-31T14:44:37+02:00 - info: ✔ PEER HYYsDawf
2017-08-31T14:44:37+02:00 - info: POST Peer HYYsDawfNi#44757
2017-08-31T14:44:37+02:00 - warn: Could not reach g1-test.elois.org:10900
2017-08-31T14:44:37+02:00 - warn: Could not reach g1-test.duniter.org:10900
2017-08-31T14:44:37+02:00 - warn: Could not reach gtest.duniter.inso.ovh:80
2017-08-31T14:44:37+02:00 - warn: Could not reach g1-test.citizengeorge.fr.eu.org:10900
2017-08-31T14:44:37+02:00 - warn: Could not reach 89.89.2.134:9331
2017-08-31T14:44:37+02:00 - warn: Could not reach g1-test.monnaielibreoccitanie.org:10900
2017-08-31T14:44:37+02:00 - warn: Could not reach g1-test.cgeek.fr:80
2017-08-31T14:44:38+02:00 - warn: Could not reach 78.251.5.57:10901
2017-08-31T14:44:38+02:00 - info: Generating proof-of-work with 4 leading zeros followed by [0-9A-E]... (CPU usage set to 20%) for block#44148 77mfxs
2017-08-31T14:44:38+02:00 - info: Cancelling the work on PoW cluster

Désolé je coller cela ici ainsi, j’espère que ça ne fait pas trop désordre.

1 « J'aime »

OK merci, ça m’aide beaucoup.

Je vais essayer de me faire un deuxième compte sur Ğ1-Test pour tester la PoW, ce sera plus pratique.

Si vous pouviez m’aider à le certifier :

Compte : cgeek-dev
Pubkey: 78Tus1ajGnztK6FW7suYsprWFZUkiiG1bakuMNsHooWo

J’ai aussi le même genre de soucis que @jellium… Je me suis demandé si mon nœud calculait vraiment. Duniter me dit qu’il y a déjà 3 blocs qui ont été calculés via mon nœud donc ça a du marcher au moins un peu. :slight_smile:

@cgeek: Je regarde pour te certifier, c’est un bon exercice.

En plus il ne m’en manque qu’une !

Cela devrait être bon à présent !

1 « J'aime »

Merci, mais je ne peux pas rentrer avant le 02/09 malgré tout :slight_smile:

Bon je ne suis pas hyper pressé non plus, hein.

Je viens de te certifier également, pour l’exercice.

Ce qui est “marrant”, c’est que je ne vois plus les autres certifications dans Cesium. (Capture d’écran)

Deux choses :

  1. Tu peux directement mettre des images sur le forum en faisant un Ctrl+V dans la zone de saisie si tu veux.
  2. En fait tu as certifié un deuxième compte nommé cgeek-dev, en réalité il y en avait deux.

Vérifies donc la clé publique certifiée, à mon avis ce n’est pas la bonne.

J’ai mis l’image “chez moi” parce que j’en profite pour commencer une mini-doc perso : mon wiki :wink:

Ensuite, tu as raison, je n’ai pas certifié le bon compte!
Honte à moi de ne pas avoir vérifié la clé publique.

Ou alors, il y a peut-être là un mécanisme général à revoir ? Par exemple est-ce que Cesium t’a demandé de vérifier qu’il s’agit bien de la bonne clé publique, le bon pseudo et la bonne date pour l’identité ?

Quand il y a une erreur d’un humain, je pense que c’est une bonne pratique de chercher les mécanismes en jeu ayant pu favoriser cette erreur.

Du coup, ensuite, reste à remonter un éventuel bug / amélioration aux développeurs de Cesium : https://github.com/duniter/cesium/issues?utf8=✓&q=is%3Aissue+is%3Aopen+

La contribution ultime étant d’aller réaliser soi-même la modification ! :slight_smile:

1 « J'aime »

J’ai bien eu un message me demandant de de vérifier certaines choses ( voir cette capture ) mais ça ne parle pas de vérifier la clé publique.

Et puisque tu violes allègrement la règle disant qu’on ne peut avoir qu’un compte certifié mais que c’est sur G1-test et que c’est pour développer, j’ai cliqué quand même. :wink:

Je vais reporter le bug si je trouve le temps dans l’après-midi. (J’aimerais bien le corriger moi-même mais n’étant pas dev accompli, ça risque de prendre du temps…)

1 « J'aime »

Je remets mon noeud Ğ1-Test en marche, je ne sais pas s’il calcule des blocs, je verrai demain et collerai des logs par ici si besoin.

Bonne rentrée, bonne semaine !

J’ai quelques soucis de mon côté également… Tout d’abord, je dois lancer l’application Duniter deux fois pour qu’elle démarre.

Ensuite, je n’ai pas l’impression que le programme calcule quoi que ce soit (malgré qu’il soit à 100% du CPU). Il me dit qu’il y a 3 blocks créés avec ma clé mais il me dit ça depuis un moment, ça n’a plus l’air d’évoluer.

Enfin, je ne vois pas mon nœud dans la liste sur http://g1-test.duniter.fr/#/app/currency/network … Je devrais voir mon IP et mon pseudo normalement, non ?

[edit: J’ajoute les logs.
Quand je lance Duniter et qu’il plante :

$ duniter-desktop 
Gtk-Message: Failed to load module "canberra-gtk-module"
2017-09-09T13:33:58+02:00 - debug: Plugging file system...
2017-09-09T13:33:59+02:00 - debug: Loading conf...
2017-09-09T13:33:59+02:00 - debug: Configuration saved.
2017-09-09T13:33:59+02:00 - debug: Opening SQLite database "/home/simon/.config/duniter/duniter_default/duniter.db"...
2017-09-09T13:33:59+02:00 - debug: Upgrade database...
2017-09-09T13:33:59+02:00 - debug: Reverting block #44099...
2017-09-09T13:33:59+02:00 - debug: Trying to close SQLite...
2017-09-09T13:33:59+02:00 - error:  TypeError: Cannot read property 'transactions' of null
    at DuniterBlockchain.<anonymous> (/opt/duniter/app/lib/blockchain/DuniterBlockchain.js:443:36)
    at next (<anonymous>)
    at /opt/duniter/app/lib/blockchain/DuniterBlockchain.js:7:71
    at __awaiter (/opt/duniter/app/lib/blockchain/DuniterBlockchain.js:3:12)
    at DuniterBlockchain.undoDeleteTransactions (/opt/duniter/app/lib/blockchain/DuniterBlockchain.js:442:16)
    at DuniterBlockchain.<anonymous> (/opt/duniter/app/lib/blockchain/DuniterBlockchain.js:406:24)
    at next (<anonymous>)
    at fulfilled (/opt/duniter/app/lib/blockchain/DuniterBlockchain.js:4:58)
Abandon

Voici les logs une fois qu’il a démarré :
Quand il vient de démarrer : http://hastebin.com/rowipokuqu
Et après un certain temps : http://hastebin.com/awecogutaj

Je relance ma demande d’aide, voici l’état actuel du réseau Ğ1-Test :

Je sais que des versions d’essais sont passées par là, mais j’aurais bien besoin que vous rebranchiez des nœuds membres en version 1.6.9.

Il vous faudra certainement resynchroniser totalement votre nœud.

1 « J'aime »

Hop me voilà de nouveau sur Ğ1-Test : http://g1-test.elois.org:10900/network/peering

1 « J'aime »

Hello !

Du coup, pour passer de la 1.6.8 à la 1.6.9, on désinstalle/réinstalle ? Pas de super fonction d’upgrade ? :slight_smile:
Autre question, elle est compatible Jessie ou pas ?

Et dernière question, j’ai toujours mes problèmes de compte indestructible. Je peux me recréer un compte sur G1-test ?
D’ici 6 mois, je serai dans la liste :wink:

Merci pour vos réponses !

Aucun soucis, on peut même faire du multi-compte sur g1-test pour des besoins de test (enfin faut prévenir un minimum quand même)

C’est quoi ce problème déja ?

Normalement, tu update le paquet debian et tu redémarres ton noeud.

A post was split to a new topic: [Demande de certifications] Patrice_F