Auth issues with Cesium

Hi there,

These days three different users reported me that they had auth issues with their Cesium. Sometimes the auth worked and sometimes the auth didn’t work in the same day.

For me this was the typical, “you didn’t type your passwords well” and their variants (spaces, caps, wrong order, etcetera), but they insisted that the passwords were correct and they asked for help sharing their passwords to friends and reported the same issue, that sometimes the auth was working and sometimes it doesn’t with the same passwords.

It tried to explain that I don’t know the cesium code, but in the case of G1nkgo, it’s all a mathematical function and if typed 2 + 2 and gives you 5 (a different wallet) you didn’t type 2 + 2, using a metaphor to explain the issue (because they were arguing about node issues or storage issues in their phones).

But I’m not 100% sure that this is the case in Cesium, doing a fast look of the code, I’m not sure that all the auth login is as simple as in G1nkgo and maybe there is a real login issue under rare circumstances (maybe some storage corruption, or I don’t know).

And this remembered me a quote (I think that is from Groucho) that was like “if ten people tell you you’re dead, it’s best to lie down” that I use when more than one person report me the same issue.

Any idea?

cc @kimamila

Je rejoins la discussion, si je ne peux pas m’en mêler vous pouvez supprimer :pray:
-j’ai fait l’ouverture d’un compte avec 1 personne, elle a choisi 1 pseudo et s’était indiqué comme libre. Du coup son compte n’apparaissait nulle part (il n’existait pas quoi, malgré la cléf et sa demande de devenir membre).

  • Je lui ai donc conseillé de changer de pseudo (car j’ai vu après que le premier pseudo qu’elle avait choisi était déjà pris, malgré le fait que Cesium lui indique que c’était disponible)
  • et là son compte est enfin apparu dans Césium :pray:
    Mais si je lui avait pas dit de changer de pseudo elle serait restée bloquée

Looking more into the code, I think that when an error of type AUTH_INVALID_PUBKEY (“The public key does not match the connected account.”) raises, all the involved code is cryptographic but with the users reports I’m not 100% sure what is going on.