Bug de synchro sur Ğ1-Test

Il me semble bien que je l’avais fait. Je retente.

Edit: j’ai bien transpilé avec yarn, reset data puis sync sur ton noeud g1-test, et j’ai encore cette erreur ruleToBeKickedArePresent.

Je pense que oui vu que j’avais vu passer la bonne version en requêtant ton noeud. Mais bon, mieux vaut assurer le coup.

Pour info je viens de faire une synchro sur g1-test.duniter.org en faisant un git checkout v1.6.20 au préalable. Celle-ci a bien terminé. Tu peux essayer cela éventuellement.

Normal que j’ai une bad gateway sur g1-test.duniter.org ?

Oui je l’avais complètement supprimé, je viens de le reconfigurer/relancer. Tu peux réessayer.

Même erreur : https://framabin.org/?7d3491795f080a6c#qZoe02sMq2OxAXZpQ6yHWukV6SeJbigtnM3S220QEh4=

Aaaaah je sais : supprime le dossier “~/.config/duniter/duniter_default/g1-test/”.

En fait tu as téléchargé une mauvaise blockchain avant le correctif 1.6.20, et du coup tu ne télécharges pas les nouveaux blocs (il reprend les tranches en cache, tu peux voir les messages filesystem:blockchain) ! Je me fais une issue pour ça, tiens (#1280).

1 J'aime

Logiquement je ne dois pas avoir ça dans “duniter_default” avec le --mdb, non ? Je vais faire ça dans mon dossier gt.

1 J'aime

@cgeek j’ai synchronisé mon noeud avec ton miroir, pas d’erreur de synchronisation et pourtant mon noeud n’avance pas :thinking:

bin/duniter sync 88.174.120.187 10904 --home /var/lib/duniter --mdb g1-test --nopeers --nointeractive
bin/duniter sync 88.174.120.187 10904 --home /var/lib/duniter --mdb g1-test --onlypeers --nointeractive

Le temps que je synchronise j’ai déjà 1 ou 2 blocks de retard et mon noeud ne prend pas le train en marche :roll_eyes:

Bon c’est pas fini mais je vois plein d’erreurs passer : https://framabin.org/?9dadf760921b1693#FygBiE4HTDCPt5g1/wpow312X92QiGhAocQCHBWQ+oE=

Tu peux tenter sans le --nopeers directement, ça passe bien maintenant.

bin/duniter sync 88.174.120.187 10904 --home /var/lib/duniter --mdb g1-test --nointeractive

C’est bon signe, c’est que tu télécharges ! :slight_smile: (j’ai pas vraiment pris le temps de gérer toutes ces erreurs, mais bon au final ça passe presque toujours).

Wouhou ça fonctionne ! Il faudrait en effet que reset data supprime ce cache :slight_smile:

Bah oui mais non, justement c’est pour pas s’embêter à retélécharger les tranches. Par contre la synchro pourrait effectivement les supprimer lors du contrôle d’enchaînement d’empreintes en cas d’échec, or je ne le fais pas :confused:

2 J'aimes

Et hop, un bug de moins =D

2 J'aimes

En fait j’ai l’impression que mon miroir ne connais aucun peer autre que …lui-même :scream:

info: Sibling endpoints:
info: BMA access: gt.melua.fr:10900
warn: Security trigger: proof-of-work process seems stuck
warn: Local node is not a member. Waiting to be a member before computing a block.
info: :heavy_check_mark: PEER droYn565
info: Next peering signal in 5 min

Si tu as synchronisé en mode --nopeers c’est normal, il faut synchroniser en mode --onlypeers ensuite pour les récupérer.

@cgeek Tu as mon noeud en peer ?

@Inso Fait plusieurs fois avec --onlypeers ou aucun des deux, je suis à jour quand je synchronize et après mon noeud fait plus rien.

Yes, depuis que tu as dit « wouhou » :slight_smile:

Pourtant il connaît bien du monde : http://gt.melua.fr:10900/network/peers

Pourrais-tu redémarrer ton noeud et nous fournir les logs des lignes qui suivent ? (pour avoir 1 minute de logs environ).

2 J'aimes

Il se tourne les pouces :grin:
https://framabin.org/?1089302e7a513bf9#qIIYQZPtZzGGj3Mu+sjJug6RUl4xdss/u20ZmHQgOk0=

C’est comme si tu n’avais pas ni BMA, ni WS2P public, ni WS2P privé d’activé. Tu peux vérifier ton fichier ~/.config/duniter/duniter_default/conf.json ?