Cesium pour vieux iOS

On a essayé d’installer Cesium sur un iPhone 4S via l’Apple Store, mais il y a un message disant qu’il faut iOS ≥11.0.

@kimamila Est-ce une vraie limitation ou une valeur par défaut ? Est-il possible de rendre Cesium accessible pour ces vieilles versions ?

1 J'aime

Je mets @bpresles en copie, car c’est le pro la dessus :slight_smile:

2 J'aimes

Oui par défaut XCode met iOS 11 en minimum. Je vais tâcher de voir si je peux builder pour iOS 9+ dans le prochain build.

Malheureusement actuellement je n’ai pas accès à mon ordinateur sous macOS (qui n’est pas un portable, mais un Hackintosh (PC en tour avec macOS installé nativement dessus)).

A mon avis je ne pourrai pas faire de nouveau build iOS avant septembre.

3 J'aimes

Bon malheureusement certaines dépendances ne sont compilés que pour arm64 (64 bits), du coup je ne peux pas builder pour des iPhone plus anciens que l’iPhone 5s (premier à être équipé d’une puce 64 bits), et ce dernier supporte iOS 11 et même 12.

Désolé :frowning:

2 J'aimes

A cause de Cordova 10 ?

De ce que j’ai vu, c’est en effet des éléments de Cordova (ou peut être des plugins). Après depuis quand Cordova (ou certains plugins) a retiré le support des CPU armv7 (32 bits), je sais pas.