Cutecoin 0.7 released

New features :

  • Sent and received lists are now ok Blockchain watching to detect new blocks and refresh the UI
  • Loading account in thread so that the UI doesn’t freeze anymore
  • Added icons
  • We now have the possibility to define a default account to load on startup
  • The user can save his password for its current session
  • Added pylibscrypt for windows client

Download link :

For ubuntu 32 bits, use “ubuntu-i686” and for 64 bits, “ubuntu-x86_64”

On linux, don’t forgot to install “libsodium” library. For ubuntu, you can find the debs files here : http://archive.ubuntu.com/ubuntu/pool/universe/libs/libsodium/
We are now waiting, has always, for your feedback :slight_smile:

1 « J'aime »

Thanks for this release!

I tried it a bit, and noticed the following:

  • In a first time, transactions were not displayed. After a moment AFK, I finally had them. Could we be noticed of that “background search” of our transactions?
  • I’ve made a transaction, without saving my password for the session. However, I’ve made a 2nd transaction and my password was already filled in (and correct, since I could validate this 2nd transaction).

Anyway, it is great to have my account loaded on startup! :slight_smile:

Bugs catched :wink:

The hotfix is available :

A preview of the future wot in 0.7.3

The non members are displayed, surrounded by a pink dashline !

As a very newbie with ucoin/cutecoin, I 'd like to test it.
On my Ubuntu14.04, I have installed libsodium and download cutecoin0.7.2. I run it, create an account, choose the node twiced.fr:9101. I see two users.
How can I create a contact with these people? Unfortunately I’m living in Munich, so I can not easily meet you guys in Paris.

Also, I have tried to send a message to these two people. cutecoin asked me several time for my password but has never given me the change to write a message. It might be a bug.

Cheers,

Hello,

glad you help us by testing the software.

You can add someone as a contact in two places :

  • In “members” list, by right clicking on the uid.
  • In the wot, by right clicking on the uid.

You’ll see there is a bug, you can add the same uid as contact many times…

Welcome out here charlyoleg! [quote=“charlyoleg, post:5, topic:117”]
Also, I have tried to send a message to these two people.
[/quote]

What do you mean by “send a message”? I don’t think we can send “messages” to others using cutecoin. We can only certify people (trust their identity) or send them money.

Thanks. It seems to work.

Hi cgeek,
I was meaning “send membership demand”. When I click on it, I have to enter my password three times. I haven’t understand yet the purpose of this button.

The purpose of this button is to send a Membership “IN” document to the community, so that people can sign you and you can join the community

The fact that you had to type 3 times your password suggests there is a bug… I’ll check for it. Do you have any logs ?
You can find the logs in ~/.config/cutecoin for linux, or in your personnal AppData for Windows.

I don’t see any log file in ~/.config/cutecoin. I only have:

  • data
  • myusername/properties

Ah yes, my bad, it will come with 0.7.3 release. I’ll try to release it asap.

Cutecoin 0.7.3 released !

Thanks to all of you, we catched a lot of bugs ! The following bugs have been fixed in this version :

  • Fixed multiple bugs when creating an account and joining a community
  • Fixed a bug when a node change its mined currency
  • Non-members are now displayed in the wot
  • Added version to window title
  • Logs are now logged to a file in application data directory
  • Posted documents are now broadcasted to all knew nodes so that the blockchain accept them faster
  • Fixed a bug when sending money twice and restarting cutecoin in between

You can download it here :

As you can see, by testing the software you are being really helpful, so please, we are as always waiting for your feedback !

I’ve try install cutecoin on Fedora. But, without success.
I download that file and run:

./cutecoin

I also installed libsodium and I always get thoses errors.
Do I’m well proceeding ?

It seems that my linux build only works for the same platform than me, archlinux.

You can try to build it. I don’t use fedora, I could help you as much as I can. Build instruction are in the README in the repository : https://github.com/ucoin-io/cutecoin

I’ll try to find why python is not frozen on linux, it looks like it is using your system libraries… Weird.

EDIT : Or it’s probably the virtual paths which look like your system path but it’s probably my syspath. Maybe I just need to find why libssl isn’t included…

Can you try the ubuntu x32_64 build, just to check ? It will probably don’t work but…

EDIT 2 : Well I guess we need a Fedora build. Can you try to build it ? I’ll help you.

With https://github.com/ucoin-io/cutecoin/releases/download/0.7.3/exe.ubuntu-x86_64-3.4.tar.gz I get those errors.
A link is make towards sources, and there is no directory to write logs.

Ah you have the same bug as cgeek.

Just create the path, it is done after trying to open the log file. It will be fixed in 0.7.4.

Quick fix, on linux :

mkdir -p ~/.config/cutecoin

On windows :

md %APPDATA%\cutecoin

Great It works :smiley:
Thanks inso.

Cutecoin 0.7.4 released

  • Multiple display bug fixed
  • Fixed bug when joining a new community
  • Fixed multiple bug when requesting the block 0
  • Fixed a bug when canceling an “add a community” action
  • Fixed the cache for multi-community requesting
  • Fixed a bug with PasswordAskerDialog
  • Fixed network errors when no endpoint could be found

This hotfix needs to the user to clear his cache
On Linux, remove

~/.config/cutecoin/[your uid]/__cache__

On Windows, remove

%APPDATA%\Roaming\cutecoin[your uid]\__cache__

This release is mostly there so that we cgeek can start the next currency, “meta_brouzouf”, without “vucoin”. Cgeek aims at vucoin to disappear.

2 « J'aime »

I’m on Ubuntu 14.04 (Ubuntu-Gnome), and it’s my first installation of cutecoin. I can’t find sodium:

$ sudo apt-get install sodium
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
E: Impossible de trouver le paquet sodium