Désactiver le plein écran de Cesium

Ya que chez moi qu’on ne peut pas désactiver le plein écran de Cesium ?

Une fois en plein écran j’ai plus de bouton pour repasser en fenêtre, et redémarrage Cesium se relance en plein écran :confused:

1 J'aime

Non, jeff, t’es pas tout seul… (Brel, le chanteur hein, pas toi…)

Moi aussi j’ai eu le problème et je touche plus à ce bouton de la mort ! :wink:

Tu peux t’en sortir de mémoire en supprimant toutes les configs que Cesium sauvegarde sur disque.
Puis reconfigurer ensuite.

2 J'aimes

Pour ceux que ça intéressent j’ai trouvé un moyen « « simple » » de désactiver ce mode plein écran si activé par mégarde:

  • Dans le fichier ~/.config/cesium/Default/Preferences
  • Changez la valeur de state:
{
   "extensions" {
       "settings" {
           "eddgpcgfbhhopcmllclnjdoiepjnmnjj" {
               "geometry_cache" {
                   "cesium" {
                           "state": 5
                   }
               }
           }
       }
   }
}

eddgpcgfbhhopcmllclnjdoiepjnmnjj est à remplacer par l’id de votre instance Cesium (je présume)

Changez 5 par 1

Cesium vous demandera poliment au prochain redémarrage si vous souhaitez garder le mode plein écran…
Choisir non lui fera prendre la dimension de fenêtre avant le plein écran.

3 J'aimes