Erreur synchro duniter


#1

Bonjour,

J’ai une erreur lors de la synchro de mon noeud duniter.
commandes effectuée:
duniter reset data
duniter sync g1.duniter.org 10901

Résultat sur cette photo (après environ 24h)
erreur_synchro_duniter

Je dois retaper les même commandes pour tout recommencer ?


#2

Tu utilises quelle version de Duniter ?


#3

1.6.25 -> OK je passe de suite à 1.7.10 -> FAIT
Je relance la synchro sans supprimer les données

Comment on accède a la webUI ?


#4

tu relance duniter avec la commande webrestart
$ duniter webrestart

et tu peux y accéder sur le port 9220


#5

la synchro avec la 1.7.10 a donné ca:
erreur_synchro_duniter_2
duniter webstart
duniter webrestart
http://ADRESSE_IP_LAN:9220 -> j’ai rien: ERR_CONNECTION_REFUSED
Est-ce que je dois donner une autorisation quelque part ?


#6

Tu utilises quelle livrable de Duniter ? Server, Desktop, Dev ?
Uniquement le livrable Desktop embarque l’interface web d’admin.
Autrement, il faut l’installer.


#7

OK j’ai la server donc c’est normal.
Comment on l installe ?


#8
git plug git+https://git.duniter.org/nodes/typescript/modules/duniter-ui.git

#9

faut obligatoirement installer npm avant (avec toutes ses dépendances)
git clone https://git.duniter.org/nodes/typescript/duniter.git
cd duniter
sudo apt-get install npm
sudo npm install

ca marche pas, une histoire de version je parie:
sudo nano /root/.npm/_logs/2019-01-17T23_43_15_994Z-debug.log
Dernières lignes:

902 verbose pkgid leveldown@4.0.1
903 verbose cwd /home/guenoel/Téléchargements/duniter
904 verbose Linux 4.9.0-8-amd64
905 verbose argv "/usr/bin/node" "/usr/bin/npm" "install"
906 verbose node v10.15.0
907 verbose npm  v5.8.0
908 error code ELIFECYCLE
909 error errno 1
910 error leveldown@4.0.1 install: `prebuild-install || node-gyp rebuild`
910 error Exit status 1
911 error Failed at the leveldown@4.0.1 install script.
912 verbose exit [ 1, true ]