Error after fresh install sakia "cannot import name QSelectorEventLoop"

OS: Arch Linux
version: 0.32.4-1

A new fresh install of sakia is now giving me this error:

Traceback (most recent call last):
  File "sakia/main.py", line 12, in <module>
ImportError: cannot import name 'QSelectorEventLoop'

I think I might have broken my Quamash fork ! I was working on optmizations, sorry about that. I need to clean up a bit all this mess…

EDIT : Ok, I’m not at home so I can’t try, but I might have repaired it. Can you try again ?

1 J'aime

I take it I’m supposed to use the dev version now.

No it’s supposed to work with aur too.

I don’t see sakia being up to date on AUR. It’s still stuck on version 0.32.4-1 while sakia’s latest github release is at 0.32.6.

[me@MyComputer sakia]$ yaourt -Ss sakia
aur/sakia 0.32.4-1 (2) (0.44)
    A Python/Qt client for Duniter network