ĞTest : Sakia 0.30 ( 0.30.11 )

:heart_eyes:

J’ai continuellement l’erreur suivante (sous Ubuntu-Gnome 16.04) :

    Task exception was never retrieved
future: <Task finished coro=<BlockchainService.handle_blockchain_progress() done, defined at sakia/services/blockchain.py:36> exception=TypeError("int() argument must be a string, a bytes-like object or a number, not 'BlockUID'",)>

    ----
    Traceback (most recent call last):

  File "asyncio/tasks.py", line 239, in _step

  File "sakia/services/blockchain.py", line 49, in handle_blockchain_progress

  File "sakia/services/identities.py", line 283, in handle_new_blocks

  File "sakia/services/identities.py", line 273, in parse_block

  File "sakia/services/identities.py", line 235, in _parse_certifications

  File "sakia/data/processors/certifications.py", line 71, in create_certification

  File "<attrs generated init 986fd8d68005efb2bfe7fbd4075432e54f205401>", line 8, in __init__
    self.written_on = __attr_convert_written_on(written_on)

TypeError: int() argument must be a string, a bytes-like object or a number, not 'BlockUID'

Apparemment, un type possible a été oublié. C’est assez gênant. Merci de regarder,

Gérard

C’est quel version de sakia ?

Oups ! Pardon. J’avais confondu le numéro de ma version et celle de la plus récente. Je vais tout de suite mettre à jour. Désolé.

Pas de soucis, j’étais surpris parce que le tracelog correspondait pas du tout au code :slight_smile:

Après mise à jour et effacement de ~/.config/sakia, j’ai tout de même eu cette erreur après récupération de l’identité :

Creating a client session outside of coroutine

client_session: aiohttp.client.ClientSession object at 0x7f25266c5128

----

Cette nouvelle version de Sakia requiert Qt 5.6+, mais mon Ubuntu 14.04 32bits n’accepte que la v5.5 max.

Donc il n’y aura plus de build 32bits Ubuntu de Sakia à l’avenir.
Désolé.

Je vais sûrement passer mon ordinateur portable en 64bit pour suivre les devs lors des RMLs.

Comme disait mon grand père :

“A un moment mon petit, dans la vie, c’est comme dans la voiture, faut passer la seconde !”

2 « J'aime »

Sakia 0.30.5 released.

Fix bugs :

  • Cannot send more than 100 lines transactions
  • balance of wallet is not updated
  • error when closing cert window
  • error on identity change
  • network tab can be slow
  • diverse networking bugs

And archlinux build is included :slight_smile: - https://github.com/duniter/sakia/releases/tag/0.30.5

4 « J'aime »

Yey ! ça roule sur ma Manjaro \o/

Petite release importante, quelques bugs critiques trainaient :

4 « J'aime »

Petite release pour Ğ1 et des corrections de bugs :

2 « J'aime »

Petite release de corrections de bugs + configuration des noeuds racines de ğ1 correcte :

ça m’intéresse de savoir comment tu as fait!

Pas encore fait, mais le hardware est déjà en 64bits.
J’avais mis un Ubuntu 32bits pour consommer moins de mémoire vive à la base.

Voilà qui est fait !

https://aur.archlinux.org/packages/sakia/

Peux tu essayer ce PKGBUILD ? :slight_smile:

2 « J'aime »

Hello, je vais essayer de regarder ça rapidement (pas gagné en ce moment, c’est la course permanente), je te tiens au jus. Merci !
sqk

@Inso :
ça a donné ça sur une install manjaro fraiche :

==> Construction et installation du paquet
==> Installation/compilation des dépendances manquantes pour sakia:
erreur : impossible de trouver la cible : openssl-1.0
==> Relancer la compilation de sakia ? [o/N]
==> ----------------------------------------
==> 

Le paquet s’appelle

1 core/openssl 1.0.2.k-1 [installed]
    The Open Source toolkit for Secure Sockets Layer and Transport Layer 
    Security
1 « J'aime »

Yep, moi aussi ça coince sur openssl-1.0, alors qu’il est apparemment bien installé sur ma machine aussi…

En fait sur archlinux il y a 2 paquets :

$ yaourt -Ss openssl
core/openssl 1.1.0.e-1 [installed]
    The Open Source toolkit for Secure Sockets Layer and Transport Layer Security
extra/openssl-1.0 1.0.2.k-3 [installed]
    The Open Source toolkit for Secure Sockets Layer and Transport Layer Security

Je dois préciser d’utiliser la version 1.0 pour la compilation de python.

Avec yaourt vous pouvez éditer le PKGBUILD avant de lancer la compilation. Il faut alors modifier la dépendance (openssl au lieu de openssl-1.0) et modifier les chemins ligne 36 :

        PYTHON_CONFIGURE_OPTS="--enable-shared" CFLAGS="-I/usr/include/openssl-1.0" LDFLAGS="-L/usr/lib/openssl-1.0" pyenv install $PYENV_PYTHON_VERSION

par :


        PYTHON_CONFIGURE_OPTS="--enable-shared" pyenv install $PYENV_PYTHON_VERSION

Pourquoi as-tu besoin de préciser d’utiliser la version 1.0 spécifiquement sous arch ?