[Important] Duniter version 1.6.21

A ceux ayant un noeud membre qui tourne sur Ğ1, merci d’installer la toute dernière version :

Duniter v1.6.21

Pourquoi ?

Un bug majeur a été découvert dans les précédentes versions, qui fait que les noeuds tentent de produire un bloc invalide. Donc sans cette nouvelle version vous ne calculerez plus aucun bloc valide.

Cela n’empêchera toutefois pas votre noeud de recevoir et accepter les blocs valides, mais il ne participera plus à l’écriture, ce qui met à mal la sécurité de la blockchain.

cc @aeris @Inso @vit … bref la trentaine de membres qui font tourner la Ğ1. Si possible faites passer le message petit à petit, nous ne ferons d’annonce officielle pour la 1.6.21 sur le blog que plus tard (cette semaine).

4 « J'aime »

Mise à jour effectuée.

1 « J'aime »

cc @MarcelDoppagne @Duarte @kimamila @poka @elois @crazypanda @nicole @DamageCo @Smyds @1000i100 @Melua @nay4 @binuts @obrow @Pafzedog @nanocryk @ji_emme

Désolé je ne suis pas du genre à spammer, mais il faut quand même un minimum de noeuds 1.6.21 pour débloquer la situation.

5 « J'aime »

La maj est déjà faite pour moi sur g1 et gt :wink:

1 « J'aime »

À jour pour ma part !

1 « J'aime »

j’arrive j’arrive !
La pression, 17 minute après la release !

1 « J'aime »

C’est fait !

1 « J'aime »

Excellent, continuez ! C’est @aeris qui a calculé le #98473. Ça repart à mesure que vous mettez à jour :slight_smile:

C’est à jour de mon coté également…
:slight_smile:

2 « J'aime »

ps : Pour ma part, n’hésite pas à spammer si c’est pour la bonne cause !
Je ne prends pas trop le temps de passer faire coucou mais je suis là quand on a besoin de moi
:slight_smile:

Mon noeud était dans les choux avec l’erreurs qu’on a vu précédement, je fait un reset data + rm du dossier des chucks, en espérant que ça suffise.

Sinon on approche du bloc #100000, on pourrait pas organiser une petite fête pour ca ? :stuck_out_tongue:

C’est noté :slight_smile: d’ailleurs on n’en demande pas plus ! Ce genre de bug est censé être relativement exceptionnel. Enfin dans l’idée :grimacing:

C’est dans environ 5 jours, soit quasiment la date anniversaire de la Ğ1. Donc ce sera Festi’Ğ1 :slight_smile:

1 « J'aime »

Je viens d’arriver, je viens de mettre a jours mes 2 nœuds membres les plus puissants, je passe au 3ème !!

EDIT : a mince je suis dans la fenêtre d’exclusion, je ne peut donc de toute façon pas calculer…

2 « J'aime »

Un message a été déplacé vers un nouveau sujet : Rencontres Festi’G1

2 messages ont été intégrés dans un sujet existant : Rencontres Festi’G1

Je suis malheureusement obligé d’attendre la version ARM.

1 « J'aime »

Mise à jour à l’instant, mais mon noeud ne redémarre pas :confused:
$ duniter webstart --webmhost 192.168.x.x
/usr/bin/duniter: ligne 36: /opt/duniter//node/bin/node : impossible d’exécuter le fichier binaire : Erreur de format pour exec()
/opt/duniter//node/bin/node v8 or v9 is required

1 « J'aime »

@binuts qu’elle est ta version de node ?

J’ai oublié de le préciser, mais en effet le livrable ARM ne sera disponible que ce soir, sauf si @jytou dégaine avant :slight_smile:

3 « J'aime »

Heu, bah voui, le noeud tourne sur un rasp.
J’attends ce soir.