Impossible de renouveler mon statut de membre


#1

Bonjour à tous,

Sur l’appli Césium sur Android, j’ai reçu une invitation à renouveler mon adhésion.
Ce que j’ai fait, ou plutôt essayé de faire, car c’est apparemment sans effet. La page d’accueil de mon compte me signale toujours que mon statut de membre va expirer dans un mois.

J’ai essayé différentes méthodes, par exemple me logger avant de cliquer sur le bouton renouvellement, changer de noeud dans les paramètres, passer par l’application web… Rien n’y fait, mon renouvellement ne passe pas.
Rien trouvé non plus quand je fais une recherche de blocs avec mon pseudo ou ma clé…

Est-ce un bug ou alors je rate quelque chose ?

Merci d’avance.


#2

Une idée me traverse soudain l’esprit : est-ce que je respecte encore la règle de distance ? Comment le contrôler ?


#3

Oui en requétant manuellement l’api BMA d’un noeud duniter

HOST:PORT/wot/requirements/:pubkey

Par exemple avec ma clé publique :

http://g1duniter.org/wot/requirements/D9D2zaJoWYWveii1JRYLVK3J4Z7ZH3QczoKrnQeiM6mx

On vois que le champ outDistanced vaut false, s’il vaut true pour toi, c’est que tu ne respecte effectivement plus la règle de distance, je ne peut cependant pas le savoir car je ne connais pas ta clé publique.


#4

Bonjour Elois.
Merci beaucoup pour ces infos.
Je viens de tester avec ma clé publique
4VZkro3N7VonygybESHngKUABA6gSrbW77Ktb94zE969
(en rajoutant le point dans l’URL :slight_smile: )
Je suis presque déçu (!) car le champ outDistanced vaut false.
Du coup, retour à la case départ. Pas d’explication au renouvellement qui ne passe pas… :frowning:


#5

ha ben je sais pas alors, réessaye demain, peut être qu’un fork a supprimé ton renouvellement :slight_smile:


#6

En fait ça fait déjà quelques jours que j’essaie, sans succès… :frowning:
Mais je réessaierai qd même demain. Je te tiens au courant.
En théorie, est-ce que le renouvellement est écrit dans le bloc généré juste après la demande, ou y a-t-il un délai ?


#7

Ben pas forcément dans le 1er block mais au bout de quelques uns, faut le temps que le document se propage a un noeud qui vas trouver le prochain block.
Après peut-être que tu est vraiment hors-distance, je crois me souvenir maintenant que @cgeek avait désactivé le calcul de distance sur l’url /wot/requirements parce que c’était trop lourd en calcul !

Dans ce cas il faut peut-être que tu obtienne de nouvelles certifications, ou que tes certificateurs en obtiennent

EDIT: Houla je suis fatigué moi, j’avais oublié qu’il existait wotex, donc non ce n’est pas la distance qui pose problème : https://g1-monit.librelois.fr/wotex?lg=fr&to=piaaf31&pending=on&mode=w2u

Du coup je ne comprend pas ce qui bloque :slightly_frowning_face:


#8

Utilise la dernière version de Césium. Il est possible que tu utilises une version instable qui comporte un bug pour renouveler son adhésion.


#9

Je crois que j’ai une piste…
@Moul , j’étais en train d’écrire quand tu as répondu. C’est justement de l’inverse qu’il s’agit !
J’ai bien la dernière version installée sur mon téléphone.
La bonne nouvelle c’est que j’ai finalement réussi à renouveler mon adhésion.
La mauvaise c’est que j’ai réussi à le faire à partir d’une ancienne version de Césium (1.0.0) que j’avais gardée sur ma tablette.

Le bug proviendrait donc de la nouvelle version de l’appli… (1.2.1) .
@kimamila @cgeek

Merci pour votre aide :slight_smile:


#10

Tout ça me fait penser que Cesium aurait peut-être besoin d’un cahier de tests fonctionnel comme on l’a mis en place pour Duniter : Cahier de tests pour les RC


#11

aie ! :frowning:
faut que je regarde ca…


#12

Merci Benoît !
En ce qui me concerne, j’ai pu contourner le problème, mais ça vaut effectivement le coup de voir si ça peut pas arriver à d’autres.
Si besoin, je peux ouvrir un compte sur g1-test pour tenter de reproduire le bug…
En tout cas si tu as une explication, je suis toujours preneur :slight_smile:


#13

Ah cool. Peux tu nous dire comment ?


#14

@kimamila il est passé par une ancienne version de cesium, il est donc probable que le renouvellement d’adhésion ne fonctionne plus dans la dernière version :confused:


#15

Bonsoir @kimamila ,
As-tu pu trouver d’où venait le bug que j’ai rencontré ? Et si oui, est-ce que la version 1.2.4 le corrige ? Je suis en fait assez surpris d’être le seul à avoir eu ce problème…

Ce qui m’amène à une 2ème question (peut-être plutôt pour @cgeek ) : est-ce que la paramètre msPeriod est aussi de 2 mois sur Ğ1Test ? (Je crains que la réponse soit oui, mais je demande quand-même :slight_smile: )
En fait je voudrais re-tester la fonction renouvellement, mais impossible de le faire avant l’écoulement de msPeriod, donc fin décembre pour ma clé Ğ1…


#16

C’est 12j sur ĞTest. :slight_smile: Et vu le temps mis à te répondre, tu peux faire le test dès maintenant !


#17

Hahaha. Je m’étais fait une raison mais Merci :slight_smile:
Je me suis donc empressé de tester de nouveau sur ĞTest
Résultats :
sur 1.2.1 Android —> Échec
sur 1.2.4 Web —> Réussite !

Je retesterai par acquis de conscience sur la Ğ1 à la fin du mois.