Installation d'un noeud de test

Est-il bien certain qu’il faille comme il est dit sur https://duniter.org/fr/contribuer/blockchain-nodejs/tutoriel-dev/chapitre-4-demarrage/ d’utiliser yarn plutôt npm étant donné que dans le package.json il est écrit

Citation
« name »: « duniter »,
« version »: « 1.8.1 »,
« engines »: {
« node »: « >= 10.19 »,
« npm »: « >= 6.13 »,
« yarn »: « YARN NO LONGER USED - use npm instead. »

Dans ce dernier cas, je crois qu’il faut tout revoir…

1 J'aime

Non ce vieux tuto n’est plus à jour, il faut se fier à la doc intégrée au dépôt, la seule qui est garantie d’être à jour, car c’est elle que je maintiens.

Mais là vous essayer de suivre un tuto de développement pour installer Duniter, il ne fait pas faire ça.

Voici la doc pour les utilisateurs de duniter :

Merci !
Est-ce que j’aurais tous les moyens de développer ?
Je vois :

Citation
cargo xtask build --production

Je peux avoir un environnement de développement ?

La documentation pour développeurs se trouve dans le dossier doc/dev : https://git.duniter.org/nodes/typescript/duniter/-/blob/dev/doc/dev

Je peux avoir un environnement de développement ?

La première étape est de bien configurer son environnement en suivant cette page : doc/dev/setup_env_dev.md · dev · nodes / typescript / duniter · GitLab

Pourquoi avez-vous besoin d’un environnement de développement ? Pouvez-vous préciser quel est votre besoin svp ? Merci :slight_smile:

2 messages ont été scindés en un nouveau sujet : Projet PolkaĞ1