Nœud Duniter sur Rasberry Pi4

Bonjour à tous

Mon nœud Duniter tourne depuis samedi dernier, mon Rasberry est paramétré à 60% de la puissance totale du processeur, et je le contrôle à distance par VNC.
Je souhaiterais comprendre tant soit peu les messages lus sur les logs.
Celui-ci est récurrent en ce moment :
– « 2020-01-06T14:16:47+01:00 - info: Fork resolution: block #285960-00000276 is known as incorrect. Skipping. »

Celui-ci également : « Unknown reference block of peer »
« 286352-02020-01-06T15:45:53+01:00 - info: [FpAi3xR2] :arrow_down: PEER HmH5beJq 286352-02020-01-06T15:45:53+01:00 - warn: Unknown reference block of peer »

Et lorsque je consulte le réseau sur Césium, je constate que je suis toujours bloqué sur le nœud 285960 (voir copie d’écran ci-dessous)

Y a-t-il quelque chose qui ne fonctionne pas bien ? Merci pour vos réponses…

Tant qu’il s’agit de info ou warn ça va.
Si tu vois des error ça peut être plus sérieux.
Je vais pas expliquer la signification des logs sans le contexte de ton nœud.
Il est possible que je dise des choses fausses.

Oui, ton nœud est bloqué, je t’invite à suivre les instructions Bloquage de la Ğ1 du 02/01/2020 dû du fait de la non exclusion d’une identité

Je t’invite à rejoindre le groupe Blacksmith pour être au courant des annonces données aux forgeurs.

Pourtant, j’ai synchronisé samedi après-midi sur g1.presles.fr et en 1h1/2 environ, c’était terminé. Dois-je refaire une synchro ? Et si oui, sur quel nœud ?

Il y a eu un autre fork entre-temps, il est possible que ton nœud soit resté bloqué.

Bon, j’ai fait une resync sur g1.presles.fr qui a bien fonctionné, et j’ai vérifié sur Cesium, cette fois-ci, ça marche, le blocage a disparu ! :smile:
Je surveille la température du Raspberry, pour éventuellement octroyer plus de puissance processeur à Duniter. Pour l’instant, je suis à 60%…

1 J'aime

Encore deux questions. La température indiquée par la ligne de commande « vcgencmd measure_temp » reste stable autour de 80°, avec une puissance allouée de 60%. N’est-ce pas trop élevé pour le petit Rasberry Pi4 ? Il est pour l’instant équipé du " Set de 4 Heat Sink Aluminium ", dans un boitier « pibow », sans ventilateur.
Par ailleurs, j’ai remarqué que la mention « accès privé » n’est plus présente pour moi sur la liste des nœuds duniter fournie par Césium. Vu qu’après la resync. j’ai redémarré duniter en ligne de commande uniquement, sans l’interface graphique, je ne sais donc pas comment valider cette option, mais est-elle bien nécessaire ? Je remarque qu’elle ne figure pas sur un certain nombre de nœuds…

Et une question subsidiaire, sur les logs, je vois régulièrement apparaitre ces deux messages :
– warn: WS2P: cannot connect to incoming WebSocket connection: WS2P connection timeout
– error: WS2P >>> >>> WS ERROR: REJECTED_PUBKEY_OR_INCORRECT_ASK_SIGNATURE_FROM_REMOTE
Y a-t-il une raison à cela, y a-t-il une correction à faire ?

C’est trop, de mon point de vue. À partir de 65-70°, ça réduit la durée de vie du processeur. Je te conseille de mettre un petit ventilateur qui changera complètement la donne en terme de température. Pour ma part, sur mes raspi3 j’ai réutilisé des ventilateurs de PC 12V 80mm que je branche sur les broches terre et 5V du raspi. Le ventilateur tourne alors assez lentement pour être totalement silencieux, mais il brasse assez d’air pour refroidir significativement l’ensemble et revenir à des températures correctes. Je pense qu’on peut faire pareil avec des raspi4.

Le mode « WS2P » de duniter permet de rendre ta connexion privée, c’est-à-dire non publiée sur le réseau : seuls les pairs auxquels tu es directement connectés connaissent ton adresse. Avantage : en cas d’attaque extérieure, ces nœuds ne sont pas directement accessibles et ne peuvent donc être attaqués facilement ; par ailleurs il est du coup pas forcément possible pour un attaquant de savoir combien de nœuds participent réellement au réseau. Inconvénient : si trop de nœuds sont en accès privé, il devient difficile d’intégrer le réseau puisqu’il y a moins de nœuds sur lesquels ont peut se synchroniser. Il faut de toute façon quelques nœuds publics pour amorcer la pompe.

Pour l’activer et le désactiver en ligne de commande, tu peux faire duniter --help et tu verras qu’il y a des options de configuration nommées --ws2p-public, --ws2p-nopublic, --ws2p-private et --ws2p-noprivate. Et si tu es nostalgique de l’interface graphique, tu peux toujours démarrer duniter avec l’option webstart et te connecter avec ton navigateur sur http://localhost:9220.

Je suppose que c’est un nœud dont le propriétaire a été membre et qui ne l’est plus, mais c’est plus mon petit doigt qui me le dit qu’une véritable analyse. :stuck_out_tongue: Ce message n’est pas grave a priori, j’en ai moi-aussi pas mal dans mes logs, ce qui n’empêche pas mon nœud de fonctionner.

2 J'aimes

Merci pour ces réponses

L’interface en lignes de commande me convient très bien, j’ai du coup sauvegardé l’aide complète dans un fichier texte. Pour le refroidissement du RPi4, vu qu’il n’est pas chez moi, je ne peux rien faire dans l’immédiat, mais je vais dès que possible lui associer un petit ventilo; en attendant, je vais réduire la puissance processeur. Et j’ai activé l’option « private »…

1 J'aime

Tu peux également modifier le fichier ~/.config/duniter/duniter_default/conf.json puis redémarrer le daemon pour que ça prenne effet.

2 J'aimes

Voilà qui est fait, j’ai réglé l’utilisation processeur à 100% et la température mesurée par vcgencm oscille à présent aux alentours de 40°. J’ai encore une question : quel est le réglage optimum de ces deux paramètres :

« You can limit the number of active private connections. »
Pour l’instant, c’est réglé à 6
« You can limit the number of active public connections. »
Là, c’est réglé à 12.
Est-ce que c’est correct ?

1 J'aime

Je n’ai jamais touché à ces paramètres, je pense que tu peux laisser les valeurs par défaut. Peut-être à baisser en cas de connexion lente, ou si tu veux diminuer la bande passante utilisée par Duniter pour la réserver à autre chose.


En fait, la question du réglage du nombre de connexions actives en mode privé et public m’est venue après avoir lu cet article d’Elois. Donc, je sollicite à nouveau une réponse à cette question, car l’article cité date de mars 2018. Qu’en est-il à l’heure actuelle ?

C’est toujours d’actu, depuis les quota par défaut avaient été mis a jours dans Duniter à 5/20 mais je pense que c’est insuffisant et qu’on devrait passer à 4/24.

Ayant installé Duniter récemment, normalement tu à déjà des quotas privé/public de 5/20, tu peut passer à 4/24 pour aider oui :slight_smile:

1 J'aime

Ok, merci pour la réponse, je vais procéder à ce réglage dans l’instant… :slight_smile: