Nouvelle version 0.20.2 disponible

Cette release fait suite à la v0.20.1 mise à disposition hier mais qui se trouvait être incorrecte.

Cette version 0.20.2 fonctionne convenablement.

Mettre à jour sa version

Détails sur le bug

La version 0.20.1 a été réalisée à partir de l’état courant de la branche master, instable, plutôt que de repartir du commit précis de la 0.20.0.

J’ai donc simplement créé une branche “0.20” temporaire qui part du commit de la 0.20.0 pour gérer les bugs bloquants de cette version, et généré le logiciel en version 0.20.2 sur cette base de code.

4 « J'aime »

Je mets @hacky, @myckeul, @kimamila, @mactov, @greyzlii, @blump et @Gat en copie, afin que vous receviez la notification : ce serait sympa de mettre à jour votre noeud, car étant donné le bug de la version précédente, votre noeud fonctionne en mode dégradé (miroir simple).

Or nous avons besoin de vrais noeuds, sonnants et calculants, afin de faire avancer la blockchain !

Ouais c’est fait :slight_smile:

Done ! :slight_smile:

Je pense que tu as utilisé le script d’installation présent sur master, or je ne l’avais pas passé en 0.20.2, je l’avais seulement fait sur la branche “0.20”. Ton noeud est donc en 0.20.1.

J’ai corrigé, tu peux réessayer : ça devrait fonctionner cette fois.

C’est mis à jour mais bizarrement je vois dans sakia que le noeud apparaît toujours en 0.20.0a8…
Pourtant :
$ duniter -V
0.20.2

J’ai bien fait
duniter stop
dpkg -i duniter-v0.20.2-linux-x64.deb
duniter start

Un truc que j’ai loupé ?

EDIT : c’est bon, le noeud vient d’apparaître en 0.20.2 :slight_smile:

1 « J'aime »

Une alerte dans Duniter Desktop qui informe de l’arrivée de la dernière version disponible en ligne serait bien. Exemple fonctionnel en HTML avec l’API github : http://geconomicus.glibre.org/latestreleases.html

1 « J'aime »

Fait !

C’est déjà développé, mais fera partie de la prochaine version non-corrective 0.21.0.

2 « J'aime »

Fait pour moi aussi :wink:

Thank you! I have installed it and it is running successfully! :grin: