Problèmes avec NPM

Bonjour, je vois passer sur diaspora des message à propos d’un problème avec la dernière version de npm qui semble être en lien avec node.js

comme je sais que c’est utiliser par duniter, je met cette alerte là

Source:

Rechercher #npmgate sur diaspora.

1 « J'aime »

Oui, visiblement ils ont fait une grosse boulette pour ceux qui lancent npm préfixé par sudo depuis un utilisateur autre que root.

Ceci dit, nous avons toujours déconseillé la compilation manuelle préfixée par sudo, pour d’autres raisons. D’ailleurs il n’y a jamais besoin de sudo pour duniter, si ce n’est l’installation du .deb.

5 « J'aime »