Problems creating a development environment for Sakia (Windows 7)

Hi there,

just trying to create a dev environment for Sakia.
OS is Windows 7.
I followed the guide https://github.com/ucoin-io/sakia/wiki/Sakia-install-for-developpers , but I get the following error:

C:\repositories>conda create -n sakia-env python=3.5 cx_freeze pyqt5 libsodium=1
.0.3
Fetching package metadata: ........
Solving package specifications: ........
Error: Unsatisfiable package specifications.
Generating hint:
[      COMPLETE      ]|##################################################| 100%


Hint: the following packages conflict with each other:
  - python 3.5*
  - cx_freeze

Use 'conda info python' etc. to see the dependencies for each package.

Note that the following features are enabled:
  - vc14

It seems cx_freeze is only compatible to Python 3.4? Do I miss something?

Yep, that’s right.

CX_freeze is not necessary for development and we will migrate on pyinstaller probably. The biggest hurdle right now for the windows dev environment is to install PyQt for python 3.5 using conda. This will probably only be available when PyQt 5.6 is out.

hmmm… just tried with Python 3.4 instead and got another problem:

[sakia-env] C:\repositories>pip install git+https://github.com/ucoin-io/ucoin-py
thon-api.git
Collecting git+https://github.com/ucoin-io/ucoin-python-api.git
  Cloning https://github.com/ucoin-io/ucoin-python-api.git to c:\users\kc\appdat
a\local\temp\pip-flsiz4ds-build
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 20, in <module>
      File "C:\Users\Kc\AppData\Local\Temp\pip-flsiz4ds-build\setup.py", line 2,
 in <module>
        import ucoinpy
      File "C:\Users\Kc\AppData\Local\Temp\pip-flsiz4ds-build\ucoinpy\__init__.p
y", line 27, in <module>
        from . import api, documents, key
      File "C:\Users\Kc\AppData\Local\Temp\pip-flsiz4ds-build\ucoinpy\documents\
__init__.py", line 4, in <module>
        from .peer import Endpoint, BMAEndpoint, UnknownEndpoint, Peer
      File "C:\Users\Kc\AppData\Local\Temp\pip-flsiz4ds-build\ucoinpy\documents\
peer.py", line 3, in <module>
        from ..api.bma import ConnectionHandler
      File "C:\Users\Kc\AppData\Local\Temp\pip-flsiz4ds-build\ucoinpy\api\bma\__
init__.py", line 91
        async def __get__(self, **kwargs):
                ^
    SyntaxError: invalid syntax

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in C:\Users\Kc\AppDa
ta\Local\Temp\pip-flsiz4ds-build

Doesn’t seem easy to get this running :stuck_out_tongue:

Dev branch is not compatible with python 3.4 unfortunately. It’s using the new async and await keywords which came with python 3.5.

Phew… ok, then I’ll drop this for now. Maybe someone with experience in python development than me can give some instructions on how to get this running in MS Windows.

lol, so or so time to get rid of it, at latest windows 10 is more spywhere then ever before :smile:
even some not nerdy friends start to switch to unbuntu.

But maybe to get used to you could install unbuntu as a second system (of course i mean primary system :))
its very easy to install, more more easy then windows, at least the last time if i happend to try to install windows for someone :smile:

That’s all propably right and I’m not eager to change to Windows 10 (still using Windows 7). But I’m Windows power user ever since I was a child (after I changed there from MS DOS :smiley: ) and even though I’m using some linux distributions from time to time, I’ve still not gotten so warm with it to change completely. Maybe I’ll try to install Sakia dev env in a VM some other day.

1 « J'aime »

lol, yea was the same for me. have been growing up with msdos :slight_smile:
I was mostly a dotnet developer, because i loved that all components worked so nicely together without having the need to configure much. is was just functioning and i cold concentrate on programming.
But nearly exactly one year ago I made the jump into the gold… cold… water and switched completely to unbuntu.
Since then it is a hard learning for me to configure all the stuff the right way, but its worth to be not hold in prison by microsoft. really time for freedom respecting software now :smile:

PyQt 5 has no prebuilt package for python 3.5. But if you are a power user, you can maybe try to build it by yourself then ! Walkthrough is here : http://pyqt.sourceforge.net/Docs/PyQt5/installation.html.
If you success, you should realize a guide with what you did :slight_smile:
The build commands should be done in the conda console, in the environment sakia-env.

Even better, you could try the conda recipe and publish the result on anaconda.org :slight_smile: https://github.com/conda/conda-recipes/tree/master/pyqt5

Conda recipes are kind of easy. A tutorial is available here : http://conda.pydata.org/docs/build_tutorials/pkgs.html

And if you need, I can probably help you during the process.

1 « J'aime »

sounds like you have some fun :smile:

Hello @Kacee, I updated the dev environment on Windows, please check it out :