Que signifie "Accès privé" sur Cesium ?

Du coup je suis sensé faire quoi ?

A tu bien pensé a faire : service nginx testconfig puis service nginx reload ?

EDIT : Aussi a tu bien redémarré duniter après le changement de config ?

entropy :: /etc/nginx/sites-available % sudo service nginx testconfig
[ ok ] Testing nginx configuration:.
entropy :: /etc/nginx/sites-available % sudo service nginx reload
entropy :: /etc/nginx/sites-available % duniter restart
Stopping duniter_default daemon...
duniter_default daemon stopped.
Starting duniter_default daemon...
duniter_default daemon started. PID: 7449

J’ai “Upgrade Required” en https://, et aucune réponse en ws://.

Mon nginx :

entropy :: /etc/nginx/sites-available % sudo cat g1.duniter.nanocryk.fr
server {
    #listen 80;
    listen 443 ssl;

    server_name g1.duniter.nanocryk.fr;

    ssl_certificate /etc/letsencrypt/live/g1.duniter.nanocryk.fr/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/g1.duniter.nanocryk.fr/privkey.pem;
    ssl_stapling on;
    ssl_stapling_verify on;

    location /.well-known {
        alias /var/www/g1.duniter.nanocryk.fr/.well-known;
    }

    location / {
        proxy_pass http://127.0.0.1:10901;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection 'upgrade';
        proxy_set_header Host $host;
        proxy_cache_bypass $http_upgrade;
    }

    location /ws2p {
        proxy_pass http://127.0.0.1:20901;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
    }
}
1 « J'aime »

@nanocryk maintenant ça fonctionne nickel chez moi, il faut tester sur wss:// quand c’est sur 443 :wink:

Ah okay il faut cliquer sur le plugin et entrer l’adresse, et pas le mettre dans la barre d’adresse de FF.

1 « J'aime »

Ben oui c’est pas du http…

Je pensais que le plugin rajoutait le support de ws(s):// dans l’URL, c’est dommage que ça ne le fasse pas :confused: En plus du coup il n’affiche pas la vue “intelligente” mais tout en ligne.

haha non ce serait trop facile :sweat_smile:

Si si, nanocryck a raison. Dans l’UI, tu peux désactiver la connexion privée, et n’autoriser que la publique. Même si par défaut, c’est plutôt le contraire.

Oui je sais mais ça ne fonctionne pas il y a déjà une issue a ce sujet, et finalement je trouverai plus logique que l’on ne propose pas d’option pour désactiver ws2p privé. (Ça reste de toute façon possible en fixant le quota outcoming a zéro, j’ai déjà tester ça).