Que signifie "Accès privé" sur Cesium ?

Salut !

Pourquoi dans la liste des serveurs une partie sont annotés “Accès privé” ?
Le miens l’est aussi, sans configuration spécifique de ma part (à part la mise à jour vers la dernière 1.6.x).

WS2P privé
Ce mode est activé par défaut et configuré automatiquement

Voir sur le wiki :

1 « J'aime »

J’avais bien désactivé ce mode auparavant. Les réglages sont écrasés par la mise à jour ?

ça je pourrais pas te dire :confused:
cc @elois ?

@nanocryk Il n’est pas possible de désactiver le WS2P Privé ! Et ce ne serait d’ailleurs pas souhaitable, lorsque BMA sera totalement supprimée (ce qui sera a terme le cas), alors WS2p privé sera absolument nécessaire.

Ce que la vue cesium nomme “accès privé” signifie en fait"pas d’accès public", ça veut juste dire dans ton cas que WS2P public est désactivé :wink:

1 « J'aime »

Ça reste quand même bizarre, vu que je l’avais activé auparavant.

Il ne suffit pas d’activer WS2P Public pour qu’il fonctionne, il faut en outre soit configuré manuellement un endpoint soit utiliser l’UPnP, si tu ne fais ni l’un ni l’autre alors WS2P, Public sera désactivé même si tu a demander a l’activer

duniter wizard network n’agit que sur BMA ?
Quel est le port “par defaut” de WS2P ?
Dans REMOTE_HOST, je dois mettre une IP ou un nom de domaine ?

oui, faudrais qu’on renomme ou supprime cette commande d’ailleurs.

Dans le code, il n’y en a pas. Par convention on utilise 20900 pour g1-test et 20901 pour g1 :slight_smile:

Un nom de domaine si tu en a un, une ip si tu n’a pas de nom de domainne

C’est bon comme ça ?
duniter config --ws2p-noupnp --ws2p-port 20901 --ws2p-host 127.0.0.1 --ws2p-remote-port 20901 --ws2p-remote-host nanocryk.fr

Est-ce que ça vaut le coup que je mette un domaine du style ws2p.g1.duniter.nanocryk.fr ? (l’idée étant d’utiliser le moint de numero de ports qui font trop “magic values”)

Ou plutôt qu’elle soit mise à jour pour gérer la conf réseau comme attendue :slight_smile: C’est quand même pratique cet assistant !

Il manque le flag --ws2p-public

Non il est préférable d’ajouter le flag --remote-path "/ws2p" et de configurer nginx comme je l’ai indiquer dans l’autre post :wink:

J’avais déjà fait duniter config --ws2p-public avant, il faut le mettre à chaque fois ?

non en effet :slight_smile:

Ticket créer : https://git.duniter.org/nodes/typescript/duniter/issues/1258

Du coup c’est l’option --ws2p-remote-path. Sinon nginx n’aimait pas upstream, du coup j’ai mis directement mon ip:port. Comment je sais si ça marche maintenant ?

Si je vais sur https://g1.duniter.nanocryk.fr/ws2p/ j’ai “Upgrade Required”.

Edit : Il faut aussi que je mette le remote port à 443, non ?

il faut tester l’adresse ws://g1.duniter.nanocryk.fr/ws2p/ avec un client WS2P, perso j’utilise l’extension firefox Simple Websocket Client, je viens de tester ton endpoint n’est pas accessible.

oui

Est-ce que je dois ouvrir d’autres ports ? J’ai un firewall d’activé.
Mes ports ouverts sont 22, 80, 443

Non aucun autre, chez moi ça fonctionne avec un firewall de nazi :stuck_out_tongue: