Renouvellement des certifications / ≥ 1.6.28 & 1.7.x

Non en réalité ils ont tous un rapport de 5 : 12 j = 60j / 5 :wink:

Ce qu’il faut retenir c’est que sur g1-test le “temps” s’écoule 5 fois plus vite pour la toile de confiance.

1 J'aime

Bien vu, c’est corrigé !

Nous avons dépassé la barre des 60%, je suis étonné que nous ne soyons pas encore passé en v11.

La mèche n’a pas l’air de prendre, si ce n’est toujours pas fait ce soir je passe en mode manuel pour forger le bloc de bascule.

Oui, j’ai également constaté ça. J’observe 65 %.

Je confirme, la mèche est trempée.

Mon noeud fera donc office de déclencheur à mon prochain bloc.

2 J'aimes

Ça y est !

2 J'aimes

Rah, j’ai également tenté de trouvé un bloc v11.
Mais, je suis passé après :slight_smile:

1 J'aime

Est-ce un évènement à inscrire dans l’historique ? :thinking:

6 J'aimes

Je ne vous en voudrai pas si vous évoquez aussi la mèche :slight_smile: un grand classique chez moi … pas assez d’énergie investie dans les choses les plus simples.

Et voilà les deux premiers renouvellements ! :champagne: :rocket: :smiley:

6 J'aimes

Oui c’est un changement des règles de la toile de confiance, ça me semble important :slight_smile:

1 J'aime

on est comment sur gtest ? je vois toujours le noeud g1-test.duniter.fr en v10.

Réponse : Renouvellement des certifications / ≥ 1.6.28 & 1.7.x

La méthode est qu’on teste d’abord sur Ğ1-test les changements de protocole.

1 J'aime

Justement, jusqu’à hier soir je n’avais pas de possibilité de tester le renouvellement anticipé.

Je me connecte via cesium sur le noeud g1-test.duniter.fr, actuellement en 1.7.8 et v10 du protocole (si j’en crois la fiche du noeud).

Du coup, est-ce que je m’y prends mal ou la propagation n’est pas effective comme le noeud n’est pas mis à jour ?

Ce matin le dernier bloc (#305 196) est bien en v11

{
    "version": 11,
    "nonce": 10100000040429,
    "number": 305196,
    "powMin": 64,
    "time": 1547101515,
    "medianTime": 1547099668,
    "membersCount": 18,
    "monetaryMass": 67905594,
    "unitbase": 1,
    "issuersCount": 5,
    "issuersFrame": 29,
    "issuersFrameVar": -3,
    "currency": "g1-test",
    "issuer": "DpJse2t7fyH9LC9FTMQHsMGZToXLmVQ8EV2eP47ipHDC",
    "signature": "nqtfZtq1qb/jo+tIA4N4mWlrAlXWegk+zsMh661T1AkQZPjRJLrukMnNHjySHuajY4+01vAXuPpZ89TLy+G/Bw==",
    "hash": "00000C640E6E05F2597EA3AD4CCF10F2BB9904C504AF50CDC55CB1A08F364025",
    "parameters": "",
    "previousHash": "00000F5156F344E9E0175700DD778A6456CA1C241F7F6C3D5397C92BAEB2383D",
    "previousIssuer": "5esxEcaSCcmAzNeaS7qF62JMzSLnsP4JXrts6KMubt4W",
    "inner_hash": "8E44920EDC4856289E96F724EABFC3D48121775FACE0C26A0133DB0F9D95A79E",
    "dividend": null,
    "identities": [ ],
    "joiners": [ ],
    "actives": [ ],
    "leavers": [ ],
    "revoked": [ ],
    "excluded": [ ],
    "certifications": [ ],
    "transactions": [ ],
    "raw": "Version: 11\nType: Block\nCurrency: g1-test\nNumber: 305196\nPoWMin: 64\nTime: 1547101515\nMedianTime: 1547099668\nUnitBase: 1\nIssuer: DpJse2t7fyH9LC9FTMQHsMGZToXLmVQ8EV2eP47ipHDC\nIssuersFrame: 29\nIssuersFrameVar: -3\nDifferentIssuersCount: 5\nPreviousHash: 00000F5156F344E9E0175700DD778A6456CA1C241F7F6C3D5397C92BAEB2383D\nPreviousIssuer: 5esxEcaSCcmAzNeaS7qF62JMzSLnsP4JXrts6KMubt4W\nMembersCount: 18\nIdentities:\nJoiners:\nActives:\nLeavers:\nRevoked:\nExcluded:\nCertifications:\nTransactions:\nInnerHash: 8E44920EDC4856289E96F724EABFC3D48121775FACE0C26A0133DB0F9D95A79E\nNonce: 10100000040429\n"
}

Tu veux dire que tu n’arrives pas à renouveler une certification avec Césium 1.3.1 hébergé sur g1-test.duniter.fr ?
Où vois-tu la v10 du protocole ? Sur quelle fiche de nœud ?

Tu parles de ton nœud ? Il écrit des blocs en v11, car il est dans la fenêtre courante. Les nœuds qui connaissent uniquement la v10 restent derrière et créent une autre monnaie.

exact, ça ne me propose rien de particulier quand je vais sur une certification déjà émise il y a plus de 12 jours.

Sur ce fichier

Laisse mon noeud tranquille :see_no_evil: !
Blague à part, je ne me connecte pas via mon nœud mais via g1-test.duniter.fr comme indiqué plus haut.

Oui, normale, on peut renouveler une certification tous les 12 jours sur la Ğ1-test.

C’est le document de pair.

Uniquement le document de bloc a évolué en v11.

1 J'aime

Bonsoir,

Je viens signaler que mon noeud a tourné deux jours avant de se désynchoniser (sur la Ğ1), avec des erreurs de type :

2019-01-24T23:26:19+01:00 - error: Unhandled rejection: Error: not opened
2019-01-24T23:26:19+01:00 - error:  Error: not opened
at WebSocket.send (/opt/duniter/node_modules/ws/lib/WebSocket.js:219:16)
at WS2PPubkeyRemoteAuth.sendACK (/opt/duniter/app/modules/ws2p/lib/WS2PConnection.js:89:18)
at WebSocket.ws.on (/opt/duniter/app/modules/ws2p/lib/WS2PConnection.js:409:79)
at <anonymous>
2019-01-24T23:26:26+01:00 - info: [CmFKubyq] ⬇ PEER GfKERHnJ 190537-0
2019-01-24T23:26:26+01:00 - info: Matched 3 zeros 00010576DF304C02BAF5005BF73842A96CC3C2E2561033946D581AD8145A7879 with Nonce = 10200000374144 for block#189845 by CmFKub
2019-01-24T23:26:28+01:00 - error: WS2P >>> >>> WS ERROR: REJECTED_PUBKEY_OR_INCORRECT_ASK_SIGNATURE_FROM_REMOTE

Je resync, j’ai conservé une copie de duniter_default. C’est utile, ou pas ?

Noeud duniter v1.7.10, sur Armbian Stretch - BananaPi.

(je mets ce message ici car Inso avait eu le même type d’erreurs)

Oui, par contre retire le fichier keyring.yml qui contient ta clé privée. Si tu veux bien, j’aimerais télécharger ton dossier duniter_default pour investiguer.