Résolu - Installation Cesium

Bonjour.
Je viens de larguer windobe pour Linux mais du coup, bien que m y étant préparer un moment, je bloque sur l installation de Cesium.

Je suis maintenant sous déviant. J ai téléchargé le paquet en .deb, et j’ai lancé l installation par la commande suivante :
dpkg -i nomfichier.deb

L installation se passe sans soucis. Je retrouve le logiciel dans mon gestionnaire, mais impossible de le lancer…

Y aurait il une subtilité qui m échappe, ainsi qu à mes recherches?

Merci de m avoir lu

Moi, je n’ai pas de problème sous Ubuntu.

Il faut installer la version desktop, mais je pense que c’est la seule en .deb.

Pour de-bugguer, lance les commandes cesium ou cesium-g1-test en ligne de commande dans un shell pour avoir un message d’erreur à nous fournir.

Comme disais Kennedy, faut pas ce laisser abattre… :wink:

Non ce n’est pas mon genre.

Alors tout d’abord l’installation avec la commande dpkg -i :

Sélection du paquet cesium-desktop précédemment désélectionné.
(Lecture de la base de données… 130619 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de cesium-desktop-v1.2.9-linux-x64.deb …
Dépaquetage de cesium-desktop (1.2.9) …
Paramétrage de cesium-desktop (1.2.9) …
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) …
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) …
Traitement des actions différées (« triggers ») pour mime-support (3.60) …

ensuite je me déconnecte et je me reconnecte.

Un petit tour dans mes programmes :

A priori il est bien installé.

1 J'aime

ensuite, dans un terminal, je lance la commande : cesium

voila le résultat :

cesium: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory

et lorsque je lance la commande : ps -e|grep cesium après avoir tenté de lancer le programme, cela ne me renvoie aucun commentaire… il n’est donc pas lancé

sudo apt-get install -y libgconf-2-4

1 J'aime

Merci @vincentux.

je vais installer ça de suite et je reviens vous dire…

au top

:star_struck::star_struck::star_struck:

Merci beaucoup pour votre aide, et ça me fait aussi voir qu’il faut que je creuse un peu ma façon de faire mes recherches…

Déterrage pour @mathieuBize
1- lance la commande cesium dans un terminal (le tableau noir).

Si le message renvoyé est libgconf-2.so.4: cannot open shared object alors il faut installer la libgconf : sudo apt-get install -y libgconf-2-4

Et normalement césium fonctionnera.

Pour info, le problème de dépendance est résolu dans les prochaines versions (1.3.x) de Cesium :slight_smile:

2 J'aimes

Bonsoir,
après avoir cherché sur de nombreux posts et pas trouvécomment résoudre ma situation je vous la soumet…
Bon déjà je ne maitrise vraiment pas bien ubuntu, mais je l’utilise pour le coté ethique de liberté.
Cela étant, quand je tombe sur un os, j’ai souvent du mal à en venir à bout…
Mais là c’est important pour moi de m’inscrire dans cette action (faire vivre un système monétaire libre et humaniste), alors voilà :
j’ai téléchargé césium pour ubuntu, je l’ai installé : tout va bien.
Mais quand je le lance l’appli ouvre une fenetre de démarrage et se referme aussitot.
J’ai testé tout ce qu’il y avait sur ce post, sans succés…
Voilà le message quand je lance « cesium » dans le terminal.
Si quelqu’un a une solution pour moi je suis preneur!
merci d’avance
[12977:12977:1104/211512.887586:ERROR:component_loader.cc(165)] Failed to parse extension manifest.
[13000:13000:1104/211512.900068:ERROR:sandbox_linux.cc(371)] InitializeSandbox() called with multiple threads in process gpu-process.
[13000:13000:1104/211512.930333:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[13000:13000:1104/211512.937012:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[13000:13000:1104/211513.061599:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[INFO] [desktop] Launching Cesium… {« debug »:false,« menu »:false,« sdk »:true,« home »:"/home/gardrat"}
[ERROR] [desktop] Error while trying to launch Cesium: Cannot read property ‹ split › of null TypeError: Cannot read property ‹ split › of null
at loadSettings (chrome-extension://eddgpcgfbhhopcmllclnjdoiepjnmnjj/cesium-desktop.js:222:96)
at startApp (chrome-extension://eddgpcgfbhhopcmllclnjdoiepjnmnjj/cesium-desktop.js:518:5)
at chrome-extension://eddgpcgfbhhopcmllclnjdoiepjnmnjj/cesium-desktop.js:553:20

Ce bug est corrigé dans la prochaine version 1.6.8 disponible ici :

https://github.com/duniter/cesium/releases/tag/v1.6.8

Voir ce billet signalant le même problème et avec la même réponse.

Un problème avec la loupe ? :wink:

Merci à toi vit,

Effectivement je n’avais pas vu ce post-là (je ne sais pas bien m’y prendre avec tout ce qui a trait à l’informatique…mais j’apprends…petit à petit!)

Du coup entre temps j’ai réussi à installer la version 1.6.1 qui fonctionne bien.
Y a t il un interet à installer la version recente?

Oui, tu dois installer la plus récente (la 1.6.8 dans ton cas).

De nombreux bugs ont été corrigés depuis la version 1.6.1.

Si tu n’es pas à l’aise avec l’informatique, installe plutôt Cesium en tant que module complémentaire pour Firefox.

Je te dirige aussi vers l’autre forum, qui répond aux utilisateurs (ici c’est pour les développeurs) :

Bonne découverte !

Merci à toi!!
:slight_smile: