[RESOLU] La synchro n'arrive pas à se terminer

Bonjour à tous, j’ai installé Duniter sur mon raspberry. Il est bien configuré (il est visible dans le réseau : duniter.jokeur.fr). Mais quand viens le temps de la synchro… c’est la galère. Pas moyen d’en finir une. Ca fini toujours par planter avec ce message d’erreur :
Status: Peers.../usr/bin/duniter : ligne 15 : 32316 Processus arrêté $NODE "$DUNITER_DIR/bin/duniter" "$@"
J’ai essayé avec plusieurs nœuds différents, avec l’option --slow, mais rien n’y fait même si avec slow c’est là que c’est allé le plus loin plus de 90% pour download et apply. Peers reste toujours à 0%
Si je met un petit numéro de bloc ça se termine tranquillement par contre.
J’avoue que j’ai pas trop d’idée sur ce qui pose problème.
Si quelqu’un a une idée je suis preneur.

D’avance merci

1 « J'aime »

Bonjour, merci de nous transmettre davantage d’informations :slight_smile:

Quelle version de duniter ?
Quelle variante (serveur ou deskop) ?
Quel OS ? raspbian ?
Quelle commande éxécute tu exactement ? (quels paramètres, mlerci de copier/coller la ligne)

Désolé j’aurais pensé à fournir ces détails :
J’utilise en effet raspbian, j’ai installé la variante serveur de duniter version 1.7.11 (ce paquet pour être exact duniter-server-v1.7.11-linux-armv7l.deb).
Pour la commande la voici :
sudo -u duniter duniter sync --slow duniter.normandie-libre.fr j’ai essayé avec les nœuds g1.cgeek.fr et g1.duniter.org aaussi

Il s’agit d’un manque de RAM. Alors, le processus se fait tuer par le noyau.

2 « J'aime »

Ah flute… C’est logique, et ça colle avec le fait que le raspberry est inaccessible quand ça plante… Bon bah… je vais réfléchir à une solution. Merci de cette réponse rapide :smiley:

Grâce à vos conseils j’ai pu trouver une solution :
j’ai augmenté la swap : http://cl-rpi.fr/index.php/2017/09/25/augmenter-swap-de-raspberry-pi/
j’ai diminué la ram alloué au GPU : sudo raspi-config > avanced option > memory split : mettre le minimum pour le GPU.
La synchro s’est bien terminé.
Merci

3 « J'aime »