Sakia 0.53.x est sorti!

Sakia 0.53.0 est sorti !

Pour l’installer ou la mise à jour :

pip3 install sakia --user --upgrade

Ou téléchargez l’exécutable Linux AppImage :

Il doit se lancer sur tous les Linux x86_64 (pas les ARMs) !

Attention : il faut ajouter les droits d’exécution !

Soit par l’interface graphique de votre système :

  • Bouton droit sur l’icône, dans propriétés, cocher « exécuter comme un programme ».

Ou en ligne de commande :

   chmod u+x Sakia-x86_64.AppImage

Puis exécuter le fichier en double cliquant dessus ou en tapant ./Sakia-x86_64.AppImage .

Au fait, Sakia est en français aussi, allez dans le menu Settings et choisissez la langue de Molière…

Nouveautés

Vous pouvez modifier les serveurs racines (pour amorcer la découverte du réseau) dans le fichier de configuration suivant :

$HOME/.config/sakia/root_servers.yml

6 J'aimes

Salut,

j’ai une erreur à l’installation avec pip3 :

ERROR: Could not find a version that satisfies the requirement sip<4.20,>=4.19.4 (from PyQt5==5.9.2->sakia) (from versions: 5.0.0, 5.0.1, 5.1.0, 5.1.1, 5.1.2, 5.2.0, 5.3.0, 5.4.0)
ERROR: No matching distribution found for sip<4.20,>=4.19.4 (from PyQt5==5.9.2->sakia)

J’ai déjà vu cette erreur, elle est due à ta version de python3.
Quelle version utilises-tu ?

C’est PyQt5 5.9.2 (la vielle version que supporte Sakia) qui a besoin d’une vielle version de sip, mais cette vielle version n’est plus disponible dans les packages de ta version de python.

Sakia a été testé uniquement avec python 3.5.x et 3.6.x.

Du coup je te conseille d’utiliser le binaire AppImage.

1 J'aime

Effectivement sur LinuxMint 20 (basée sur la dernière LTS Ubuntu 20.4) la version de python3 est :

~$ python3 --version
Python 3.8.2

–> Go AppImage