Souci cesium par navigateur?

Impossible de me connecter avec Firefox , ça dit
"une page web ralentit votre navigateur. Que voulez-vous faire ?" arrêter ou patienter … si on patiente tout bugge, même le seul onglet ouvert de ce forum…

Et sous Chrome, impossible d’afficher la page, enfin à moitié … puis ça plante … impossible d’afficher la page

Y’a que moi ?

Aurais tu par hasard l’addon “Privacy Badger” ? si oui autorise cesium dans ses options.

1 « J'aime »

heu non … et fin de matinée, y’avait aucun souci … je n’ai rien rajouté au navigateur

C’est aussi un problème qu’on peut rencontrer quand son OS n’a pas été mis à jour depuis des lustres. Les navigateurs ayant évolué ne sont plus compatibles.
Si ce n’est pas non plus le cas, je passe la main à Kimamila.

non c’est à jour … je n’ai pas de souci sur d’autres sites …

Quelle adresse a le cesium que tu cherches à joindre ?

ça fait pareil avec le navigateur safari de mon vieux aïephone …
Pafzedog, l’adresse a changé depuis ce matin ? o_O
sinon, c’est https://g1.duniter.fr/#/app/home

il y a plusieurs instances de cesium en libre accès donc c’était pour tester celle qui te pose problème :wink:

1 « J'aime »

ah mais oui … je l’ai mise au dessus
et ça fait pareil sur https://duniter.fr/g1/#/app/home

il y a une instance sans https aussi pour tester
http://g1.duniter.org/cesium/#/app/network

ça vient de me faire la même chose : “une page web ralentie votre navigateur”

yep ça marche sans https !!!

1 « J'aime »

y’a bien un souci …
A signaler sur Github ?

je l’ai signalé sur le chat, tu peux sûrement ouvrir une issue sur github, ça fait toujours plaisir aux devs :wink:
contrairement à toi, il n’y a que la première adresse qui me pose problème.

il doit y avoir un truc par là https://github.com/duniter/cesium/commit/95f85f416eca9857f864d35f71a5698d77e96856

@Carole_Fabre peut tu tester si ça fait pareil sur mon cesium et celui de mlo ?

https://cesium.g1.ifee.fr/
https://cesium.monnaielibreoccitanie.org

impeccable ! ça marche !

Kimamila est au courant, c’est la dernière release de Cesium qui bug !

Merci @Carole_Fabre. Visiblemement ma dernière version de Cesium (v0.11.2) fontionne mal sous Firefox ;(
J’ai été trop confiant sur ce coup là.

Il s’agit essentiellement d’une mise à jour pour gérer automatiquement le bascullement HTTP (page network) / HTTPS (pour sécuriser d’avantages les autres pages), tout en conservant les paramètres (langue, le noeud DUniter, etc.)…

Bon le code ne me plaisait pas trop non plus, du coup je penses que je vais retirer cette focntionnalités, pour simplement afficher un message, dans la vue réseau, indiquant que seuls les noeuds configurés en HTTPS y sont visibles. Eventuellement je y pourrais aussi un lien pour ouvrir un explorateur de réseau dédié (en HTTP, donc).

Bref, pour ce soir :

  • ne mettez pas vos Cesium à jour (conservez l’ancienne version 0.11.1)
  • utiliser les autres instances de Cesium (indiquées plus haut), en pensant bien à NE PAS cocher “Se souvenir de moi”. :wink:

A+
Benoit.

3 « J'aime »

ok :slight_smile: et bon courage pour la suite