Wotwizard ne fonctionne plus

Hello tous,

ce matin, wotwizard ne répond plus : 502 Bad Gateway me répond le navigateur.

Je le signale à toutes fins utiles…

cgeek est averti.

Ah, nouveau message d’erreur : il me dit aujourd’hui que le certificat certbot est obsolète…

:pensive:

J’ai bientôt terminé l’industrialisation de WotWizard, ce message d’erreur va disparaître en même temps.

Désolé du temps que cela prend, mais j’ai très peu de créneaux pour m’occuper de cela.

5 J'aimes

Il faut attendre quelques heures pour la propagation DNS, mais déjà le site est accessible en HTTP : http://wotwizard.duniter.org.

Pour les plus pressés, vous pouvez vérifier en ajoutant cette entrée dans votre fichier /etc/hosts :

91.121.157.13	wotwizard.duniter.org
2 J'aimes

J’en profite pour indiquer que le certificat de https://duniter.org/fr/ est lui aussi obsolète :confused:

Oui !!!
Merci.

La piscine n’est pas encore pleine. Ça viendra.
Il y a un problème d’affichage lié à l’encodage des caractères. On peut corriger localement ou il faut modifier le fichier html sur le serveur ?

J’ai modifié le fichier.

J’ai mal modifié les DNS, la propagation se terminera cette nuit. Je pourrais corriger le HTTPS demain midi.

J’ai modifié mon etc, et ça marche bien.
Je ne sais pas comment tu obtiens le temps de calcul, mais je vois 0s. Dans le fichier WWResult.json, le champ meta.computation_duration le donne en secondes. J’obtiens chez moi une valeur de quelques secondes.

La propagation DNS est terminée, et le certificat HTTPS réinstallé : cette adresse fonctionne bien : https://wotwizard.duniter.org.

Aussi, au niveau des URLs :

C’est assez simple de le savoir avec le navigateur Chromium :

  • touche F12 (outils de développement)
  • onglet Sources
  • dans la colonne de gauche Page > fichier (index) (sous-entendu par Chromium : index.html)
    image
  • descendre ligne 137 (le fichier est tout petit), mettre un point d’arrêt (clic sur la colonne de gauche), puis faire F5 :

Le fichier HTML peut être corrigé directement ici : https://github.com/duniter/WotWizard/blob/master/www/index.html. Puis il suffit à une personne de l’infra (Inso, Moul, cgeek, …) d’appliquer les changements. Pour l’instant, je suis le seul à pouvoir les appliquer vu que je n’ai pas encore publié le code d’infra de WotWizard.

2 J'aimes

J’ai changé de stratégie, voyant que, historiquement, c’est plutôt wot-wizard qui est cité comme URL principale plutôt que wotwizard.

Et j’ai changé les configurations. Du coup :

Bref, WotWizard est censé être de nouveau accessible à tous. :champagne: :fireworks: :slight_smile:

7 J'aimes

J’ai corrigé cela aussi.

3 J'aimes

OK, mais la ligne 137 est fausse. La valeur de computation_duration est déjà en seconde, il ne faut pas la diviser par 1000.

Oui, précisément, je montre comment s’apercevoir du bug. Il n’y a plus qu’à le corriger, qui se lance ?

1 J'aime

Je crois que c’est bon, j’ai modifié le html. Il reste à l’appliquer.:slightly_smiling_face:

2 J'aimes

Fait. :slight_smile:

Parfait !

1 J'aime