Cesium > compatible avec les vieilles versions d'Android ? (ex: 4.2.2)

Android 4.2.2, ça passe ?

Faut croire que non :

A toi de faire le test :wink:

1 J'aime

Les autres versions de Cesium passaient ?

Non, ça fait un moment que les dernières versions de cesium ne fonctionnent pas sur mon téléphone …

@Candidesk8 Ne t’avais je pas déjà indiqué, lors d’une remarquable similaire de ta part, que Cordova (utilisé par Cesium) avait un compatibilité limité avec les versions dAndroid ?
(minSdkVersion)

Cesium utilise la dernière version stable de Cordova (10.0.0) et de Cordova-android (9.0.0).
Voici le tableau de compatibilité :

La version minimal pour Android est donc l’API 22.

Je viens de corriger dans la construction de l’APK. Ainsi l’installation du fichier APK devrait détecter dès le début l’incompatibilité.

En revanche, tu peux toujours tenter de construire une version de Cesium en modifiant les versions de Cordova (dans lepackage.json) et le minSdkversion (dans config.xml). Après tout le code est libre :slight_smile:

2 J'aime

J’ai jamais fait ça. Pour utiliser cesium depuis mon ordinosaure mobile, j’ai adopté la méthode du fichier HTML du point ZiP

1 J'aime

Je comptais justement testé si une version de Cesium avec un vieux Cordova et un target SDK plus ancien fonctionne. Je penses que oui, il faut seulement modifier 2-3 dépendances, à la construction du fichier APK, mais pas besoin de modif de code dans Cesium

1 J'aime

Si tu construit une telle version « rétrocompatible », je suis disponible pour la tester sur mon appareil :wink:

J’ai jamais compiler de logiciel de ma vie …