Césium et Césium-YNH (Yunohost)

Bonjour à tous,

En mettant à jour le yunohost derrière https://duniter.be/ , j’ai remarqué que cesium-ynh ne collait vraiment plus par rapport aux versions de Césium.

La dernière release de Césium : 1.3.11
Césium-ynh essaye d’installer la version : 1.4.12

C’est moi et @Moul qui avions fait une bidouille pour la 1.4.12 mais finalement, ça m’a pété dans les doigts. J’ai fait un fork pour reconfigurer cesium-ynh pour qu’il installe la dernière release (1.3.11 donc).
( https://github.com/SimonLefort/cesium_ynh )

Mais il faudrait peut-être qu’on définisse vers quoi on veut aller ?
Est-ce qu’on remet cesium-ynh sur la version 1.3.11 ?
Est-ce qu’une nouvelle release officielle est prévue (parce qu’il y a plein de pre-release.)

@kimamila , si tu as une minute ? :slight_smile:

Salut !
En fait mon idée était de vérifier que Cesium n’a plus le problème de blocage « Veuillez patientez » (à cause d’une

backdrop qui ne se masque plus).

C’est un bug aléatoire, donc pas facile à dépister…
Dès que ce problème complètement résolu, nous passerons la v1.4.x en release.

a+

As-tu une idée du temps que ça va prendre ?

Si ça prend plus de deux semaines, par exemple, peut-être que ça vaut la peine de repasser Cesium-ynh en 1.3.11 et mettre à jour à la prochaine release officielle.

Je veux bien m’en occuper, j’ai juste envie qu’on soit alignés. :slight_smile:

1 J'aime

L’autre bug trouvé sur la 1.4.12 est quand même fort gênant.

@SimonLefort, si tu veux prendre la main sur la mise à jour des versions sur cesium_ynh, je veux bien te la donner. Je serais pour rester sur la 1.4.x, mais si tu as des raisons (gros bugs) de passer en 1.3.x, vas-y. Perso, je m’en sers qu’en lecture seule pour monitorer la monnaie sauf pour envoyer des renouvellements d’adhésions tous les ans, car Silkaj ne sais pas encore le faire.

La dernière que j’ai utilisé en local et stable était la 1.4.6.

@Moul : Je veux bien prendre la main dessus.

Par contre, mon objectif (et le but de ce post) est qu’on réaligne les versions du Césium-ynh avec les releases « officielles » de Césium. Pour qu’on ne casse pas tout chez tout le monde à chaque upgrade de l’app.

Si la dernière version « sans bugs » est la 1.4.6 comme dit @matograine, est-ce possible de la mettre en release et de partir sur cette base ?

@kimamila, qu’en pense-tu?

Je ne suis pas encore utilisateur de ce packagé, donc sentez vous libres :slight_smile:

N’est-ce pas aussi possible d’avoir deux versions ? Une stable et une instable ?

Tu as dû recevoir, à l’époque, une invitation dans tes mails pour entrer dans le groupe YunoHost-Apps / Duniter. Je peux essayer de renvoyer si tu ne remets pas la main dessus.

Après, je comprends pas bien pourquoi tu veux downgrader. Admettons.

Il est possible que je rencontre ce bug. Je fais souvent des CTRL + F5 afin que ça ne reste pas bloqué sur le spinner de chargement.

@kimamila : En l’état, le package Cesium pour Yunohost récupère la dernière release lors de l’installation (la v1.3.11 donc). D’où mon questionnement pour voir si on force le package dans une version plus récente ou si on attend une release officielle. :slight_smile:

C’est possible de maintenir plusieurs versions en passant par un fork comme je l’ai fait mais ça veut dire que tu es déjà en train de faire du bricolage. Il n’y a qu’à seul package qui apparait via l’installateur de yunohost.

@Moul : Je ne souhaite pas particulièrement downgrader.

Mais à l’époque, on avait passé une version 1.4.12 (de mémoire) en release le temps de mettre à jour le package Yunohost. Donc le package yunohost installait Césium 1.4.12.

Sauf que la dernière fois que j’ai mis à jour Yunohost (ce week-end), il m’a proposé une mise à jour pour Césium qui a juste pas fonctionné et m’a obligé à réinstaller complètement l’application. Mon objectif c’est de remettre le package Césium-ynh à niveau par rapport à aux releases officielles de Césium pour éviter les plantages lors des mises à jours. (Et il y a aussi d’autres choses qui sont dépréciées et que j’aimerais remettre à jour. :slight_smile: )

Je vais regarder pour ce mail mais là comme ça, ça me dit rien.

C’est toujours le cas, il installe la 1.4.12. Une release avait été supprimée de la forge on a dû mettre à jour.

Dans ce cas il faut étudier ce qu’il s’est passé et le corriger. Tu devrais pouvoir retrouver les logs dans /var/log/yunohost/categories/operation/*app_upgrade-cesium.log.

Je vais creuser ça.

Merci pour le mail d’invitation.