Cesium : nouvelle version v1.6.12

Pouvez-vous m’aider à tester sur la nouvelle version 1.6.12 de Cesium.

Mon objectif est d’avoir (enfin) une version unique qui marche nickel pour toutes les plateformes, afin de mettre à jour cesium.app.

Je vais essayer (avec votre aide !) de faire une mini cahier de test, dans un prochain post. @matograine tu n’avais pas commencé à en faire un ? Je ne sais plus…

Après validation d’une version stable, mise en production, je passerai les scripts de constructionpour gérer les versions SemVer (-alpha, -beta, etc.) pour ainsi être plus précis à votre égard, et que chacun s’y retrouve (cc @moul).

Déjà, merci à tous pour votre patience !

Cahier de test - Cesium v1.6.12

  • Mobile :
    • Android
      • Depuis le fichier APK
    • iOS : en cours de déploiement
  • Extension :
  • Version desktop :
    • Debian / Ubuntu :
      • Ubuntu 16
      • Ubuntu 18
      • Ubuntu 20
      • Linux Mint 20.1
      • Ubuntu 20.04.2 LTS
      • Debian Buster
      • Quelles autres contribs ?? A décider suivant les testeurs possibles
    • Windows
      • 7 - 64 bits
      • 10 - 64 bits
      • Autres versions ?
    • MacOS
      • Quelles versions ?
  • Web
    • mode normal (lecture/écriture)
    • mode « démo » (lecture seule)
    • mode « monitoring »

Si les tests son OK :

  • Déploiement de la version :
    • Android :
      • Play Store
      • FDroid
    • Mise à jour de cesium.app
    • Instances web :
      • g1.le-sou.org (en mode démo)
      • g1.e-is.pro (en mode monitoring)
      • Autres instances à tester ??
    • Communication :
      • feeds-*.json (page d’accueil Cesium) - fichiers sources à mettre ici
        • feed-fr.json
        • feed-en.json
        • feed-es.json ?
        • feed-it.json ?
3 J'aime

La mise à jour via l’apk pour Android n’a pas fonctionné.
Après désinstallation de l’ancienne version, l’installation à réussi, quelqu’un reproduit ?

Oui, tu ne peux pas installer le fichier APK, si la version précédente a été installée depuis le Play Store.
Ce n’est pas une erreur.

1 J'aime

Absolument.

1 J'aime

5 messages ont été scindés en un nouveau sujet : Cesium > compatibilité vielles versions d’Android (ex: 4.2.2)

Je viens d’ajouter la version desktop de windows : https://github.com/duniter/cesium/releases/download/v1.6.12/cesium-desktop-v1.6.12-windows-x64.exe

Salut :slight_smile:
J’ai essayé d’installer l’extension Chrome avec le fichier .crx mais ça ne fonctionne pas. :frowning:

  • Par contre en utilisant le dossier extension de navigateur ça fonctionne très bien. :white_check_mark:
  • J’ai installé l’extension pour Firefox, ça fonctionne très bien également. :white_check_mark:

J’attends de pouvoir tester les versions MacOS et iOS quand elles seront disponibles.
Amicalement :blush:

Oui Chrome bloque car ils obligent à passer par le Chrome Store

1 J'aime

Installé sans problèmes et fonctionnel sous Linux Mint 20.1 :slight_smile:
(Désolé mais il m’est impossible de modifier le topic en mode wiki)

J’ai ajouté ta version :wink:

1 J'aime

Hello.

Installation parfaite sur Ubuntu 20.04.2 LTS :slight_smile:

Personne pour tester sous Windows ? Mac ?

ok sur ubuntu mate 20.04

2 J'aime

Sur Windose 8 :

comportement étrange lors de l’ajout d’un portefeuille à « mes portefeuilles » : après avoir cherché un portefeuille à ajouter et l’avoir sélectionné, il est directement ajouté sans que j’aie besoin de valider.

edit - ça n’a sans doute aucun rapport, mais je l’indique quand même : après la session de W$ où j’ai installé et testé CS, mon ordi refuse de booter Debian, il ne boote que sur Windose.

cahier de tests

Paramètres

changer de noeud Duniter

Création de compte

Membre

créer un compte membre (GTest !!)
La licence s’affiche lors de la création du compte membre
il est proposé de sauvegarder le document de révocation

Portefeuille

créer un compte portefeuille
remplir les infos Cesium+

Transformation

transformer un compte portefeuille en compte membre (GTest !!)
la licence est affichée
il est proposé de sauvegarder le document de révocation

Certifications

envoyer une certification depuis mon compte
certifier une identité depuis son compte
avertissement si certification d’une clef pub portant sur plusieurs identités (non testé)

Transactions

ouvrir l’interface d’envoi des transactions depuis l’accueil
ouvrir l’interface d’envoi des transactions depuis la page d’un compte
retrouver une id
retrouver une clef pub
retrouver un pseudo Cesium+
sélectionner un portefeuille parmis « mes portefeuilles »
changer l’unité DU/Ğ1
envoyer une transaction en Ğ1
envoyer une transaction en DU

Sécurité

document de révocation

sauvegarder
publier (GTest !!)

création de fichiers de trousseau

PubSec
WIF
EWIF

authentification par fichier de trousseau

PubSec
WIF
EWIF

authentification par scan de QR-Code (pour ordiphones)

clef publique
WIF
EWIF
PubSec (?)

fichier de sauvegarde des identifiants

création
utilisation

Mes portefeuilles

[*] ajout d’un portefeuille. Comportement étrange : je recherche le pseudo du portefeuille à ajouter, je le sélectionne, le portefeuille est directement ajouté sans que j’aie besoin de valider.

1 J'aime

Ne serait-il pas judicieux de commencer à automatiser ces tests pour Cesium ?

Que ce soit les tests d’environnement (lancement sur VM windows ou conteneur debian/ubuntu/Arch/RedHat).

Mais aussi des tests plus classiques :

End 2 End tests : https://www.joshmorony.com/e2e-end-to-end-testing-in-ionic-2-an-introduction/
Unit tests : https://www.joshmorony.com/test-driven-development-in-ionic-2-an-introduction-to-tdd/

3 J'aime

Je suis d’accord avec toi, surtout que gitlab a un service de CI très élaboré et on trouve des images docker windows sans problèmes.

Euh… Non, le principe des containers c’est d’utiliser les ressources de l’hôte. Comme nos serveurs sont sous Linux, impossible de lancer un container Windows dessus. Il faut absolument un hyperviseur de VM et une VM Windows. Amha.

2 J'aime

Ah :smiley:

petit test user sur version desktop Windows 10 Fam - 64
duniter 1.6.12 wf10.txt (2,5 Ko)
petit test user sur version chrome extension
duniter 1.6.12 chrome.txt (1,2 Ko)

3 J'aime

Je penses avoir trouvé le soucis, finalement : le versionCode de l’APK était movaux, et inférieure à la version précédente.

  • La version 1.6.7 avait versionCode = 106070
  • La version 1.6.12 avait versionCode = 106012 => c’est à dire < 106070

J’ai donc fait un HotFix en relivrant le fichier APK de la v1.6.12, avec cette fois versionCode = 106120.
Peux tu tester @vincentux que c’est toujours ok avec cette nouvelle version ?

1 J'aime