Duniter version 1.4

J’ai modifié le fichier, et depuis mon nœud à l’air de bien se synchroniser.
Au redémarrage le cpu était à 35%, je l’ai poussé à 67% tout va bien pour l’instant…

Bon je suis bloqué au blocs #45596, @cgeek les logs sont parlant ou pas ?

2017-08-21T09:14:43+00:00 info Pulling blocks from the network...
2017-08-21T09:14:44+00:00 info Block resolution: 0 potential blocks after current#45596...
2017-08-21T09:14:44+00:00 info Will pull blocks from the network in 0 min 25 sec
2017-08-21T09:14:53+00:00 warn Pulling not finished after 10000 ms, continue PoW
2017-08-21T09:14:56+00:00 info Transaction 7CEAC5DE7B392A1DF6067295B171335A2828954B6D2EBF6B54F2A12A3EA57A8A added to block
2017-08-21T09:14:56+00:00 info Generating proof-of-work with 5 leading zeros followed by [0-9A-D]... (CPU usage set to 4%) for block#45597 5dzkze
2017-08-21T09:14:56+00:00 info Cancelling the work on PoW cluster
2017-08-21T09:14:56+00:00 info GIVEN proof-of-work for block#45597 with 5 leading zeros followed by [0-9A-D]! stop PoW for 5dzkze
2017-08-21T09:14:56+00:00 warn The proof-of-work generation was canceled: Proof-of-work computation canceled because block received
2017-08-21T09:14:59+00:00 info ⬇ PEER D9D2zaJo

je viens de remarquer que si je mets cpu 80%, mon nœud calcule le premier blocs à 80%, mais ensuite pour le blocs suivant le cpu est divisé par 2 (40%) et ainsi de suite, à chaque nouvelle tentative de calculer un nouveau bloc le cpu est divisé par 2, pour tomber à 0 :roll_eyes:

1 « J'aime »

Peux-tu monter ton niveau de log à “debug” avec :

duniter config --loglevel debug

Puis redémarrer ton nœud ? J’aurais besoin des 2-3 premières minutes de log après démarrage.

Arf, j’utilise Shell in a box pour me connecter au rpi mais je ne peux pas copier/coller les logs :frowning:
regarde via le lien pour partager les logs via l’interface de duniter (mais je dois pas avoir le début)
https://hastebin.com/itovexucaq

Je sais pas qui a développé cette fonction, mais waow le type est prévoyant ! :rofl:

En tout cas, ton nœud est parfaitement sain de ce que je vois. D’ailleurs tu es bien synchronisé sur une des branches de fork actuellement (car oui, il y a un fork depuis ce matin) :

Si je le croise un jour, faudrait que je le félicite :stuck_out_tongue:

Sinon cette histoire de % de cpu qui se divise par deux a chaque fois… une idée ?

duniter2.txt (225,6 Ko)

Pour désactiver l’option débogue du log, Quelle mot clef doit-je mettre?

Merci.

C’est le code que je vous ai montré plus haut, il divise par deux mais en plus se remémore de cette valeur, donc il la redivise à chaque preuvre à réaliser.

Je vais tout de même vérifier avant, constater sur mon propre raspi.

Remplace “debug” par un autre niveau, comme “info”, “warn” ou “error” :

duniter config --loglevel info

Merci

Je vous invite à vous mettre à jour en version 1.5.

https://forum.duniter.org/t/duniter-version-1-5/3063

1 « J'aime »

Bonjour tout le monde. :grinning:
Je suis également sous Raspberry Pi 3 et j’ai installé la dernière version de Duniter qui effectivement me semble synchroniser beaucoup mieux.

Cependant dans Cesium, ces derniers jours de temps en temps je voyais mon noeud en gris dans la colonne « Noeuds miroirs » mais dès que je cliquais dessus, « message d’erreur, impossible de récupérer les informations » puis en actualisant la page, le noeud disparaît.

Capture d’il y a quelques minutes :
Par contre donc je ne vois pas apparaître mon noeud nul part et les autres toujours en gris

Là pour le moment, a priori je suis synchronisé :slight_smile:

Pouvez-vous m’aider SVP ?
Ça me tient à coeur vraiment cette monnaie libre et j’aimerais vraiment arriver à faire fonctionner l’ensemble et ensuite arriver à rencontrer des membres, mais comme je l’ai déjà dit, ça va être difficile, je crains énormément les trajets de part mon handicap :blush: mais malgré tout, j’aimerais vraiment que ce système se développe ici aussi dans le Sud-Est.

Par ailleurs le jours où vous voulez organiser une conférence ou autre pour montrer et apprendre, je suis preneur ! :slight_smile:

Un grand bravo pour votre travail.

Merci #HappyShares & #Gratitude For All!

1 « J'aime »

Quel Cesium ? Utilises-tu un Cesium web, desktop, module de Duniter ?

En tous les cas ton nœud indique dans sa fiche de pair :

BASIC_MERKLED_API duniter.adn.life 2a02:8434:2d10:a800:4c8f:5e4a:aa05:3342 8999
BMAS duniter.adn.life 443

Mais quand je teste :

Je tombe à chaque fois sur ce qui ressemble à un port fermé, une absence de réponse. Donc c’est normal que tu apparaisse en gris, ton nœud est injoignable.

Merci pour la réponse @cgeek c’est gentil.
En fait pour Cesium embarqué à Duniter, je ne comprends pas quelle version est-ce… ou qu’est-ce que Cesium embarqué directe à Duniter ?

Si non, dans mon cas sur mon Raspberry Pi 3 j’ai installé YunoHost puis Duniter, et enfin j’ai installé la version Cesium YunoHost, là je viens de faire :

sudo yunohost app upgrade cesium -u https://github.com/YunoHost-Apps/cesium_ynh

tout c’est bien passé pour ma console de commande, pourtant, même en relançant le Pi, il m’affiche la version 0.16.0 … je ne comprend pas.
Même en navigation privée.

Pour Duniter, je suis sur YunoHost aussi, la mise à jour elle, c’est bien passée et semble active.
Pour le port je ne comprends pas, je vais aller vérifier si je n’ai pas oublié d’en ouvrir un sur ma box.

Merci pour votre aide :slight_smile:

Déjà pour Cesium, télécharges plutôt la version pour Bureau. Moins restrictive sur les aspects réseau, elle t’évitera des pièges inutiles : https://github.com/duniter/cesium/releases/download/v0.17.1/cesium-desktop-v0.17.1-linux-x64.tar.gz

(il te faut la dézipper et cliquer sur « index.html »)

Note : Cesium n’est pas Duniter. Ce sont 2 choses bien différentes : Cesium est un client tandis que Duniter est le cœur du réseau, de la blockchain, etc.

Pour le port, oui, vérifies. Essaies aussi de cliquer sur les URL que j’ai mentionné plus tôt, tu dois avoir un retour sinon il est certain que ça ne fonctionnera pas pour nous.

1 « J'aime »

Merci,
je viens de vérifier les ports sur la box, j’ai oublié le 53…
Le Pi reboot et je vous dit ça :slight_smile:

En fait j’ai téléchargé aussi cesium bureau pour tester, c’est vrai qu’on voit plus les connexions en vert :slight_smile:
Je viens de rebooter box et Pi mais a priori…

Bonjour tout le monde :slight_smile:
malgré l’ouverture supplémentaire du port 53, redémarrage box et raspberry pi, comme d’habitude suivit de sudo duniter webrestart malgré un reboot du pi car sinon erreur 502 nginx bad gateway…
Comme les autres jours, le noeud est en gris, non-joignable donc…

Je ne comprends pas et reste dubitatif… le noeud semble se synchroniser et les ports sont ouverts.

Sinon j’avais bien compris la différence entre le noeud Duniter (le coeur) et les clients comme Cesium, ce que je ne comprends pas c’est l’expression en ces termes comme j’ai pu lire « Cesium embarqué a Duniter » quesaquo ?
Pour moi je comprend le Client directement incorporé au Coeur si vous préférez, mais bon ce n’est qu’un détail, l’essentiel et que les Clients Cesium, Sakia… voient mon noeud Duniter.

Dans ipv4 j’ai déjà essayé avec d’autres config (lo 127.0.0.1 …) mais c’est comme ça (tout en none) où j’ai l’impression que ça fonctionne le mieux.

je suis SFR Box, mais j’ai ouvert les ports comme indiqué sur le forum comme pour livebox, mais j’imagine que se sont les mêmes ports à ouvrir ?
Déjà ssh, smtp, ftp… tout ça c’est tout le temps pareil pour des tas de choses, ensuite le 8999, le 53…
Non, franchement pour l’instant je sèche.

  1. Mets None à IPv6.

  2. Mets une adresse “192.168.x.y” dans IPv4. Sinon tu nœud sera effectivement injoignable, il doit écouter une interface réseau atteignable par ta box, typiquement les 192.168.x.y.

  3. Tu peux aussi activer UPnP, je pense que ça sera salvateur ici, en complément de 2.

Puis bien sûr tu valides avec « Save and apply ».

Attends un bon quart d’heure, mais déjà les URLs précédentes devraient répondre.

1 « J'aime »

Super ! Merci @cgeek je vais essayer, en farfouillant sur le forum à force j’avais trouvé ton début de réponse là => [Résolu] Installation noeud Duniter / Yunohost / Raspberry

je vous tiens au jus, j’y crois, aller Feu ! :slight_smile:

Bon ca n’a pas fonctionné…
j’ai tout virer, j’essaie de réinstallé Duniter, il me dit qu’il n’arrive pas à récupérer le paquet par le front end et en ligne de commande il me dit => unable to download https://github.com/duniter/duniter_ynh/archive/master.zip
Bon, je vais retrouver le lien où il y a les explications pour un reset all.
A+ je vous tiens au jus.

Bon j’édite ma réponse car ma réinstallation n’a pas fonctionné 502…
Je suis en train de passer par =>
duniter reset all
duniter sync g1.duniter.org 443

Je vous dis après si je suis arrivé à refaire fonctionner le noeud, je suis blasé car je vais perdre la clef alors que je suis sûr qu’il ne manquais pas grand chose pour être visible correctement…

Bon ça m’a carrément gonflé ! J’ai les boules mais grave ! Ça ne fonctionne plus du tout encore une fois…
même dans la console une fois que j’ai réglé le fichier conf.json, je fais un sudo duniter webrestart et rien, il ne se passe rien, comme si il n’arrivait pas à se lancer…
Du côté version sur le web via l’interface de YunoHost, dans les services, Duniter est arrêté et message d’erreur quand je veux le lancer…
Ça sent la ré-installation encore une fois, c’est très pénible et dommage, je ne vais pas tout ré-installer 50 fois non plus…

Je ne sais pas quoi faire, fatigué, épuisé et plus rien ne fonctionne correctement :frowning: alors que depuis plusieurs jours au final, mis à part que le noeud était un coup visible un coup non, duniter fonctionnait sans message d’erreur et il se synchronisait… là mis à part erreur 502…

La suite au prochain épisode.

Merci.

Alors pour information, je viens de tenter une installation via la console de commande, voilà une capture d’écran du code erreur, installation failed =>

Avis aux amateurs, si vous savez ce qu’il se passe… moi j’arrête là pour l’instant.


Bonsoir à toutes et à tous.
Excusez mon agacement d’hier soir, mais j’ai trop insisté ces jours-ci et la santé m’a rattrapé… d’où mon humeur du fait que je n’y arrivais plus. :blush:

Néanmoins, je ne lâche pas comme ça…
Calmement tout à l’heure j’ai farfouiller sur mon pi et j’ai remarqué que pas tous les fichiers de Duniter n’avaient été supprimé.
J’ai donc fait un sudo rm -r /root/.config pour supprimer le dossier de config… :slight_smile:
Ca a commencé à fonctionner, j’ai pu réinstaller Duniter puis upgrade.

Là j’en suis à la synchronisation =>
J’ai tenté en premier lors du choix de choisir un backup que j’avais fait il y a 2 jours, j’ai eu un message import data puis rien… du coup tant pis pour la Clef, j’ai les boules mais bon, au pire j’essaierais d’installer le backup si j’arrive à faire re-afficher l’interface web synchronisée sans erreur déjà… :slight_smile:
Croisez les doigts SVP, désolé encore pour hier soir.

Bon, une fois l’installation faite, direction settings pour vérifier la config car message d’erreur à l’accueil comme quoi le noeud n’est pas visible… je change ma config essaie d’appliquer, rien ne se passe, je retourne à l’accueil erreur 502 nginx…

Je suis donc maintenant sur mon fichier /root/.config/duniter/duniter_default/conf.json j’ai essayé pas mal de configurations différentes, avec reboot du Pi puis sudo duniter webrestart mais rien n’y fait…

je re-tente une config et je vous poste mon conf.json si vous voulez bien y jeter un oeil svp.