Duniter version 1.4


#21

Nous rencontrons un problème identique avec mententon. Impossible de lancer l’install de duniter 1.4. 14 ni .15 ni aucune ancienne version. J’ai renomé le dossier .config/duniter pour voir si cela changeait quelque chose mais rien du tout. L’installation ne se lance tout simplement pas.

Edit: le problème vient tout simplement d’une probable MAJ Ubuntu. C’est un bug de l’installeur par défaut.
Mententon a tenté l’install via gdeby et nous voila revenus dans la partie.

sudo apt install gdeby

si d’autres rencontrent le même soucis.


#22

Tu as un problème particulier je pense, car tu as une palanquée de “Could not reach [X,Y,Z]”. Tu as peut-être un pare-feu qui empêche tes requêtes sortantes.

Je vérifie quand même qu’il ne s’agit pas d’un bug mal nommé …


#23

Bon en fait c’est un bug : le message d’erreur est incorrect, il y a une erreur sous-jacente qui n’a rien à voir avec un problème réseau. Je vais voir si je peux faire une version corrective.


#24

Bonjour cgeek,
j’ai installé un noeud sur Raspbery Pi 3 via YunoHost, un peu galéré mais là il semble que le noeud soit fonctionnel, pourtant il apparaît que quelques micro-secondes dans les noeuds miroir sur Cesium 0.16 alors qu’il apparaît dans l’onglet Peers sur Duniter, c’est duniter 1.4.15 c’est pour ça que je me permets de poster ici car j’ai l’impression que dès que je change d’onglet sur l’interface web, hop il re-synchronise…
Le max que ça a tenu avec fenêtre web ouverte 35 min, après ça recommence, ça tient 2-3 min et re-synchronise.
Du moins pour ce que j’observe depuis tout à l’heure.
le lien vers log si vous voulez => https://hastebin.com/vodavipujo
Le noeud c’est https://duniter.adn.life:8999

Par contre du coup je n’arrive pas à connecter Cesium avec mon noeud, il mouline un moment pour se connecter mais après message d’erreur impossible de se connecter ou vérifier l’adresse.

Par avance merci pour votre aide et si ça peut aider via les logs :slight_smile:


#25

Je ne peux malheureusement pas beaucoup aider ces prochains jours, je suis uniquement les problèmes généraux et urgents, et même cela je peux difficilement intervenir

Je pourrais aider de façon plus particulière dans 1 semaine.


#26

Pas de soucis, je comprends. :slight_smile:
C’est sympa déjà de se rendre disponible de temps en temps.
Bonne soirée à tous.


#27

Est-ce que l’on peux “downgrader” vers une version inférieur pour ne pas avoir le problème en attendant?


#28

Oui, mais veille bien à faire un “reset all” avant.


#29

Bon pour l’instant j’arrête de m’acharner sur mon nœud pour qu’il veuille bien rejoindre la branche principale :sob:
Du coup il reste sur 666 blocs calculés, un signe ? :scream:

Et voila un aperçu de mes logs dans duniter ui :confused:

et ceux la proviennent de la commande : sudo duniter logs


#30

Si tu veux tester, tu peux installer la v1.5.1 (encore en pre-release) qui devrait totalement et définitivement débloquer ton nœud :

Pour un nœud ARM :

wget https://github.com/duniter/duniter/releases/download/v1.5.1/duniter-server-v1.5.1-linux-armv7l.deb
sudo dpkg -i duniter-server-v1.5.1-linux-armv7l.deb
sudo su
duniter webrestart

Puis LAISSE ton nœud faire son boulot tranquillement. Il devrait être occupé bien 5 minutes à résoudre tous les forks qu’il va rencontrer.

Tiens moi au courant :slight_smile:


#31

J’aimerais rester avec une installation via yunohost…

Est-ce que je peux forker le dépot duniter_ynh et modifier la ligne 5 du fichier duniter_ynh/scripts/functions.sh pour le faire pointer vers https://github.com/duniter/duniter/releases/tag/v1.5.1 ?
Est-ce que ça fonctionnera ? :thinking:


#32

Ça revient au même. Ce que je viens de te donner comme commandes, je les ai justement exécutées sur mon nœud YunoHost.

Mais tu peux tout aussi bien forker le script comme tu le suggères, oui !


#33

Bon j’ai forké le dépôt, modifié le fichier, mais… :sob:

admin@YunoHost:~ $ sudo yunohost app upgrade duniter -u https://github.com/vincentux/duniter_ynh
Warning: wget: missing URL
Warning: Usage: wget [OPTION]... [URL]...
Warning: 
Warning: Try `wget --help' for more options.
Error: Unable to upgrade duniter
Error: No app to upgrade

#34

Ben oui faut pointer vers l’URL du fichier, je pense.


#35

J’ai installé la 1.5.1 sur un de mes nœuds et j’ai le même problème que sur la version 1.4.15: la synchronisation ne se fait pas correctement. A ce jour seul la version 1.3.14 fonctionne correctement sur mes Raspberry pi (sans Yunohost)


#36

Qu’est-ce que ça signifie précisément ? Par exemple depuis cette version 1.5.1, mon nœud est enfin de nouveau synchronisé et visible, donc il n’y pas de raison que ce ne soit pas ton cas !


#37

Je n’ai pas de problème avec le nœud en 1.3.14.
Avec le nœud en 1.5.1 j’ai depuis hier (jour de l’installation):

Au niveau du log:
2017-08-21T09:42:07+02:00 warn Identity with hash ‘CB888269B21616DB837F8DCDCC65B8A776B1897D8DDA90600F9F9099BDC6C349’ not found
2017-08-21T09:42:27+02:00 info Generating proof-of-work with 5 leading zeros followed by [0-9A-D]… (CPU usage set to 60%) for block#45484 7G2mS5
2017-08-21T09:42:27+02:00 warn The proof-of-work generation was canceled: Cannot read property ‘cpu’ of undefined
2017-08-21T09:42:27+02:00 info Generating proof-of-work with 5 leading zeros followed by [0-9A-D]… (CPU usage set to 60%) for block#45484 7G2mS5
2017-08-21T09:42:27+02:00 warn The proof-of-work generation was canceled: Cannot read property ‘cpu’ of undefined
2017-08-21T09:42:29+02:00 info :arrow_down: PEER CRBxCJrT
2017-08-21T09:42:48+02:00 info :arrow_down: PEER FoBUPzML
2017-08-21T09:43:03+02:00 info :arrow_down: PEER 3wdDzBz1
2017-08-21T09:43:09+02:00 info :arrow_down: PEER 7vU9BMDh
2017-08-21T09:43:30+02:00 info :arrow_down: PEER DwurzjXe
2017-08-21T09:43:32+02:00 info :arrow_down: PEER 887ZzEtL
2017-08-21T09:43:35+02:00 info :arrow_down: PEER 4GX5gUFw
2017-08-21T09:43:42+02:00 info :arrow_down: PEER 3AF7bhGQ
2017-08-21T09:43:55+02:00 info :arrow_down: PEER D9D2zaJo
2017-08-21T09:43:58+02:00 info :arrow_down: PEER TENGx7Wt
2017-08-21T09:44:01+02:00 warn Identity with hash ‘D9F1F20AAD555D94139B49B30176FEB55FCE92E901A724357FE9FB286207FA38’ not found
2017-08-21T09:44:01+02:00 warn Identity with hash ‘2F8D80833B1DC88DA7C8C33AE8CE016B79689AFE052F90B4AE59B5868119C852’ not found
2017-08-21T09:44:01+02:00 warn Identity with hash ‘D9F1F20AAD555D94139B49B30176FEB55FCE92E901A724357FE9FB286207FA38’ not found
2017-08-21T09:44:01+02:00 warn Identity with hash ‘2F8D80833B1DC88DA7C8C33AE8CE016B79689AFE052F90B4AE59B5868119C852’ not found
2017-08-21T09:44:13+02:00 warn Identity with hash ‘1BA301344F263E05A913A6A045AEF0708FBA5845E1D7E13CF78F0944C5F43227’ not found
2017-08-21T09:44:13+02:00 warn Identity with hash ‘1BA301344F263E05A913A6A045AEF0708FBA5845E1D7E13CF78F0944C5F43227’ not found
2017-08-21T09:44:17+02:00 warn Identity with hash ‘CB888269B21616DB837F8DCDCC65B8A776B1897D8DDA90600F9F9099BDC6C349’ not found
2017-08-21T09:44:18+02:00 warn Identity with hash ‘CB888269B21616DB837F8DCDCC65B8A776B1897D8DDA90600F9F9099BDC6C349’ not found
2017-08-21T09:44:29+02:00 info :arrow_down: PEER FEkbc4Bf
2017-08-21T09:44:29+02:00 info :arrow_down: PEER gtAf2Rm7

  • Toujours le problème de “cpu” (présent depuis la version 1.4.15).
  • Le CPU du raspberry Pi est toujours inférieur à 30% alors que sur le nœud en version 1.3.14 il est à 60%, limite mise sur les deux nœuds.

#38

Version 1.5.1 installé, et même soucis que @stephane :frowning:


#39

J’entends le problème du calcul. Ceci dit il aurait été plus efficace de me faire un ticket GitHub, car c’est l’outil de suivi des bugs. Sans ticket il faut vraiment que je me rappelle que tel problème existe, et vu le nombre de choses à penser, ça risque fort de passer à la trappe (ce fut le cas ici).

Pour la synchronisation qui n’avance pas, le problème est vraisemblablement lié. Je vais vérifier.


#41

Question : vous êtes bien tous deux sur ARM ?