Installation de Sakia sous Xunbuntu

Bonjour,

J’avais déjà tenté avant de créer aujourd’hui mon compte sous Cesium, mais sans résultat:
module téléchargé, le programme Sakia apparaissait dans ma liste de programme, mais impossible de le lancer.

Là, nouvelle tentative, téléchargement de sakia-linux.deb, le gestionnaire de programme me propose de l’installer, il s’installe, je le voit dans la liste des programme et dans le raccourcit/barre de lancement, mais impossible de le lancer!

Comme Xubuntu est basé sur Ubuntu, j’ai téléchargé le .deb sur les conseils de Jean : Rejoindre la monnaie avec Sakia

les tuto n’abordent pas ma problématique, je n’ai pas trouvé de post sur le forum qui y réponde non plus (problèem d’install, mais autre config) d’où mon post!

Merci pour les éventuelles réponses que vous pourrez me faire.
Candide

As tu la moindre erreur de lancement ?

Peux tu tapper dans la ligne de commande “sakia -d” et nous copier/coller les retours ?

merci :slight_smile:

Bonsoir Citoyen, aurais tu installé la version Béta réservée aux tests avancés? 0.30.0beta… est faite pour touner sur une autre monnaie parallèle: "fake-net"
La version stable de test actuelle est la 0.20.13 que tu peux télécharger ici
edit: oups désolé inso, post presque simultané…

Sinon il y a un petit logiciel qui me simplifie ma vie de noob linuxien qui s’appelle “synapse” à ne pas confondre avec synaptic, qui est un petit launcher qui prend instantanément en compte tout programme même fraichement chargé.
(Pour ma part, Duniter requière souvent un redémarrage que je m’évite avec synapse même si un “duniter desktop” ou un “sakia” fonctionnent très bien en terminal)

Bonjour à tous et merci pour vos retour!

Voila :

Une précision, mon système est Lubuntu et non Xunbntu, j’ai du tester les deux et je confond toujours un peu … noob, moi? naann :wink:

Comment je fais pour vérifier la version logicielle? On voit ça sous le gestionnaire de programme?

c’est ici que j’ai téléchargé mon sakia-linux.deb

Je crains que la version linux ne soit faite que pour les systèmes 64 bits !

Pour les versions 32 bits, tu devras attendre que quelqu’un en fabrique une pour toi… D’habitude c’est @vit, tu devras attendre qu’il

Hello, @inso, j’ai le même souci, je viens d’installer sakia et il ne se lance pas.
J’ai téléchargé sakia-linux.deb sur GitHub en version Sakia 0.32.8. Installé avec l’outil d’installation logiciel “logiciels”.

Je suis sous le dernier xubuntu LTS 64 bits.

Il apparaît dans la liste des logiciels et je clique dessus mais rien ne se passe.

Si je le lance en ligne de commande j’ai ceci:

PyInstaller Bootloader 3.x
LOADER: executable is /opt/sakia/sakia.bin
LOADER: homepath is /opt/sakia
LOADER: _MEIPASS2 is NULL
LOADER: archivename is /opt/sakia/sakia.bin
LOADER: pyi_arch_check_cookie failed
LOADER: Search for cookieLOADER: package found skipping digital signature in /opt/sakia/sakia.bin
LOADER: Extracting binaries
LOADER: Executing self as child
LOADER: set _MEIPASS2 to /opt/sakia
LOADER: LD_LIBRARY_PATH=/opt/sakia
PyInstaller Bootloader 3.x
LOADER: executable is /opt/sakia/sakia.bin
LOADER: homepath is /opt/sakia
LOADER: _MEIPASS2 is /opt/sakia
LOADER: archivename is /opt/sakia/sakia.bin
LOADER: pyi_arch_check_cookie failed
LOADER: Search for cookieLOADER: package found skipping digital signature in /opt/sakia/sakia.bin
LOADER: Already in the child - running user’s code.
LOADER: Python library: /opt/sakia/libpython3.5m.so.1.0
LOADER: Loaded functions from Python library.
LOADER: Manipulating environment (sys.path, sys.prefix)
LOADER: Pre-init sys.path is /opt/sakia/base_library.zip:/opt/sakia
LOADER: sys.prefix is /opt/sakia
LOADER: Setting runtime options
LOADER: Initializing python
LOADER: Overriding Python’s sys.path
LOADER: Post-init sys.path is /opt/sakia/base_library.zip:/opt/sakia
LOADER: Setting sys.argv
LOADER: setting sys._MEIPASS
LOADER: importing modules from CArchive
LOADER: extracted struct
LOADER: callfunction returned…
LOADER: extracted pyimod01_os_path
LOADER: callfunction returned…
LOADER: extracted pyimod02_archive
LOADER: callfunction returned…
LOADER: extracted pyimod03_importers
LOADER: callfunction returned…
LOADER: Installing PYZ archive with Python modules.
LOADER: PYZ archive: out00-PYZ.pyz
LOADER: Running pyiboot01_bootstrap.py
LOADER: Running pyi_rth_qt5.py
LOADER: Running pyi_rth_qt5plugins.py
LOADER: Running pyi_rth_pkgres.py
LOADER: Running main.py
Traceback (most recent call last):
File “sakia/main.py”, line 8, in
File “/home/travis/.pyenv/versions/3.5.4/lib/python3.5/site-packages/PyInstaller/loader/pyimod03_importers.py”, line 573, in load_module
ImportError: /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1: undefined symbol: drmGetDevices2
Failed to execute script main
LOADER: OK.
LOADER: Cleaning up Python interpreter.
LOADER: Back to parent (RC: 255)
LOADER: Doing cleanup
LOADER: Freeing archive status for /opt/sakia/sakia.bin

Si tu as des infos pour m’aider c’est le bienvenue :wink:

Oui, sur github une solution a été trouvée : https://github.com/duniter/sakia/issues/768

Ha t’es un lève tôt aussi!, ok je vais allez voir, merci :wink: @Inso

1 « J'aime »

Ok j’ai fait ce qui est proposé, ça se lance…! :wink:

1 « J'aime »