Installation Duniter sur Raspeberry Pi - Yunohost - derrière Freebox v5

Bonjour,

Je tente vainement d’installer un nœud Duniter sur un Raspberry Pi avec Yunohost derrière une Freebox v5 (ip fixe).

Je me suis appuyé sur les tutoriels de @Moul et @Thatoo.


J’ai créé un domaine (laurent-st-math.fr) et un sous-domaine (duniter.laurent-st-math.fr) sur 1and1.

J’ai créé les domaines et sous-domaines correspondants sur Yunohost.

La commande > host me donne pour chacun d’eux :

J’ai tenté d’abord d’installer Duniter sur le sous-domaine duniter.laurent-st-math.fr. Si je lance curl, j’obtiens :

Par ailleurs, je n’arrive pas à accéder à l’interface de mon nœud.

Pour simplifier, j’ai tenté d’installer mon nœud directement sur le domaine laurent-st-math.fr sans plus de résultat.

Lors de l’installation, j’ai eu les messages d’erreur suivants :

À la fin, j’obtiens quand même un succès de l’installation.

Est-ce que j’oublie quelque chose ou me plante quelque part ? Toute aide est la bienvenue car je suis vraiment en galère.

Benoît

1 « J'aime »

essaye
sudo yunohost app install https://github.com/YunoHost-Apps/duniter_ynh

Bonjour @Thatoo,

Ok, l’installation est en cours…

Par contre, quelle est la différence entre :

sudo yunohost app install https://github.com/YunoHost-Apps/duniter_ynh
sudo yunohost app install https://github.com/duniter/duniter_ynh ?

C’est le même dépôt. Je l’ai juste déplacé d’organisation.

Dans ce cas, je crains que le résultat ne soit pas meilleur. J’ai déjà procédé à 4 ou 5 réinstallations soit en ligne de commande soit par l’interface.

Je confirme, ça ne fonctionne toujours pas mieux :rage:

Aurais-tu une ancienne installation sur cette machine ?

En tous les cas la désinstallation ne supprime pas les données il me semble. Donc avant de réinstaller, tu devrais supprimer le dossier /root/.config/duniter. Puis tu pourrais réessayer.

La configuration et les données sont bien supprimées à la suppression de l’application.

1 « J'aime »

Une voie de recherche à exclure, donc.

Lors des 2 dernières installations, j’ai eu ce message d’erreur :


Est-ce grave ?

Est-ce que d’autres ont installé derrière une Freebox comme moi ?

J’ai du mal à identifier le problème. Puis-je vérifier différemment qu’avec l’interface web si mon nœud est bien lancé ? Est-ce plutôt un problème de résolution DNS ? Ce n’est pas des choses que je fais tous les jours. Je n’exclue pas m’être trompé sur ces aspects.

J’ai l’impression également que ton nœud n’arrive pas à synchronsier.

Que donne une curl duniter.org:10901 ?

@cgeek Voici :

Quand j’affiche les nœuds miroirs sous Cesium, mon nœud apparaît bien mais quand je clique dessus, il tourne en rond.

Ah oui donc ton nœud tourne très bien ! Je le vois également.

Bon après investigations il y a quand même plusieurs soucis pour accéder à ton nœud (bien que lui n’ai aucun problème à accéder au réseau).

Le domaine duniter.laurent-st-math.fr

host duniter.laurent-st-math.fr 
Host duniter.laurent-st-math.fr not found: 2(SERVFAIL)

J’ai bien compris que tu n’as pas installé ton nœud sur ce domaine, mais si tu le fais nous ne pourrons pas, dans l’état actuel de résolution du DNS, joindre ton nœud. Et ce indépendamment des autres problèmes.

Le HTTP 302

Quand tu fais un curl laurent-st-math.fr, tu obtiens un retour Nginx HTTP 302. C’est en fait la redirection YunoHost vers HTTPS.

En tentant de la suivre avec l’option -L, on a cette fois un problème de certificat HTTPS auto-signé. Contournons avec l’option --insecure, et finalement on a avec la commande curl -L laurent-st-math.fr --insecure la page de login YunoHost.

Donc, j’en déduis que c’est ta configuration YunoHost pour Duniter qui est problématique. Si laurent-st-math.fr est la page d’accès principal à YunoHost (ou la page d’accès par défaut, je ne sais plus), ça peut être gênant pour la configuration.

Je te conseille donc de :

  1. Paramétrer le DNS duniter.laurent-st-math.fr pour qu’il ait une IP (peut-être as-tu une réponse à cause d’une entrée dans ton /etc/hosts)
  2. Désinstaller Duniter
  3. Le réinstaller sur le domaine dunter.laurent-st-math.fr

C’est déjà quelque chose ! :slight_smile:

Je ne suis pas bien sûr de bien savoir comment faire.
J’ai réservé mon domaine chez 1and1. Où se fait la résolution pour le sous-domaine ? Chez 1and1 ou dans Yunohost ?
Je me suis basé là-dessus : https://yunohost.org/#/dns_subdomains_fr.
J’ai transposé et j’ai tenté de paramétrer le sous-domaine chez 1and1 comme suit :

Comme j’ai écris plus haut, je maîtrise mal ces aspects de réseau et de dns.

C’est dans 1and1 le soucis.

Je pense que tu devrais avoir : CNAME: laurent-st-math.fr.

Cela signifierait que duniter.laurent-st-math.fr est un nom commun (Common NAME, CNAME) de laurent-st-math.fr. Et donc qu’il faut considérer le sous-domaine comme si on s’adressait à laurent-st-math.fr. Là, j’ai l’impression qu’on a une référence récursive, c’est même étonnant que 1and1 t’ai autorisé cette valeur.

Et ça expliquerait aussi pourquoi on n’a pas de résolution sur ce sous-domaine.

Ok. Dans mon sous-domaine, dans 1and1, j’ai modifié l’alias en laurent-st-math.fr. J’obtiens ça :

Par contre, ça va demander un peu de temps avant que la mise à jour soit appliquée.

1 « J'aime »

Oui, réessayes dans 3h minimum à mon avis :slight_smile:

edit : quoique, moi ça se résout correctement désormais pour duniter.laurent-st-math.fr. Je crois que c’est assez rapides pour les nouvelles entrées DNS, c’est la modification qui est plus lente (or même si tu modifies là, vu qu’il y avait une erreur, c’est comme s’il s’agissait d’une nouvelle entrée …).

Et du coup, il faut quand même je désinstalle / réinstalle Duniter après ?

Oui, sur le nouveau domaine. C’est YunoHost qui veut ça.

C’est parti ! On y croit ! :slight_smile:

Bon… L’installation est finie mais ça n’est toujours pas mieux j’ai l’impression :rage:.

Je ne parviens pas à accéder à l’interface web avec l’adresse :
duniter.laurent-st-math.fr/webui.

J’ai encore la même réponse :

Edit : je rectifie, c’est déjà beaucoup mieux : mon noeud est reconnu du monde extérieur puisqu’il apparaît bien sous Cesium ! Il a l’air bien synchronisé puisqu’il connaît ses petits camarades ! :fireworks: