Livrables ARM en attente : Raspberry PI 3 HS

Je suis étonné; c’est presque indestructible…tu as marché dessus? :thinking:

Il y a des chances que ce soit la carte SD. Mais je ne veux pas la reformater, je vais attendre d’en recevoir une autre pour vérifier que c’est bien elle le problème.

Tu peux déjà faire un pre-diagnostique avec l’état des leds rouge et vert.

Oui justement, je n’ai que la LED rouge d’allumée sans clignotement.

Tu as donc raison, cela peut venir de la carte SD.
SI tu ne veux pas la reformater, tu peux faire une image sur PC avec Win32DiskImager

J’utilise plutôt un OS et des logiciels libres, aurais-tu ? Pour Ubuntu.

De mémoire il y a la commande dd

Ah oui … bon je vais voir, j’ai un peu de temps ce soir.

C’'est hors sujet mais je fait régulièrement avec cron des sauvegardes de tous mes raspberry pi avec le code suivant (à adapter):

SERVER=“xxx” # IP of Network disk,
USERNAME=“xxx” # FTP username of Network disk
PASSWORD=“xxx” # FTP password of Network disk

sudo mkdir /mnt/sd-backup
TIMESTAMP='/bin/date +%Y%m%d%H%M%S'
sudo mount -t cifs -o username=$USERNAME,password=$PASSWORD //$SERVER/storage/sd-backup /mnt/sd-backup
sudo touch /mnt/sd-backup/backup.log
sudo chmod 777 /mnt/sd-backup/backup.log
LOGFILE=/mnt/sd-backup/backup.log
NAME=$(uname -n)
echo $TIMESTAMP Start backup $NAME >> $LOGFILE
FILENAME=sd-$NAME_$TIMESTAMP.img
FILE=/mnt/sd-backup/$FILENAME
sudo dd if=/dev/mmcblk0 bs=1M of=$FILE >> $LOGFILE && sync >> $LOGFILE
sudo umount //$SERVER/storage/sd-backup
sudo rm -Rf /mnt/sd-backup

J’ai branché la carte SD sur mon laptop, visiblement c’est bien elle qui a rencontré un problème :

cgeek@xps13-cgeek:~$ sudo dmesg | grep mmcbl
[22173.723718] mmcblk0: mmc0:d555 SD032 30.6 MiB 
[22297.635990] mmcblk0: mmc0:d555 SD032 30.6 MiB 
[22310.455773] mmcblk0: mmc0:d555 SD032 30.6 MiB (ro)
[22335.436019] mmcblk0: mmc0:d555 SD032 30.6 MiB (ro)
[22391.440118] mmcblk0: mmc0:d555 SD032 30.6 MiB 
[22470.344718] FAT-fs (mmcblk0): bogus number of reserved sectors
[22470.344722] FAT-fs (mmcblk0): Can't find a valid FAT filesystem
[23675.486106] mmcblk0: mmc0:d555 SD032 30.6 MiB 
[24297.523910] mmcblk0: mmc0:d555 SD032 30.6 MiB (ro)
[24316.595848] mmcblk0: mmc0:d555 SD032 30.6 MiB 

Je ne sais pas trop comment la recouvrer, pour l’instant je ne vois qu’une partition de 32 Mo. Bien sûr la carte refuse les mount.

Attention avec les dd de filesystems montés (si c’est le cas). Une écriture pendant la sauvegarde corrompra celle-ci.
Je recommenderais plutôt un rsync :).

Je n’ai pas eu de problème depuis plus de 3ans en faisant ça…:thinking:

Peut-être avec testdisk…

1 « J'aime »

J’ai fait ce que j’ai pu, mais la carte est définitivement détectée avec une taille de 32 Mo, et m’affiche plusieurs erreurs concernant ses secteurs.

Mais j’ai reçu une nouvelle carte ce midi, tout fonctionne nickel.

Je vais refaire une livraison de Duniter avec ARM ce coup-ci :wink:

1 « J'aime »

@cgeek, as-tu remis ton Raspberry en marche?

Quand j’install la version 1.6.4 sur Raspberry pi, j’ai cette erreur:
module.js:597
return process.dlopen(module, path._makeLong(filename));
^

Error: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.21’ not found (required by /opt/duniter/node_modules/sqlite3/lib/binding/node-v48-linux-arm/node_sqlite3.node)
at Error (native)
at Object.Module._extensions…node (module.js:597:18)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object. (/opt/duniter/node_modules/sqlite3/lib/sqlite3.js:4:15)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)

Peux-tu préciser quel OS tu as sur ton raspberry pi ?

Raspbian Jessie sur Raspberry Pi2

[Edit]: j’ai cette erreur avec la version 1.6.3 également mais pas sur la 1.5.9

J’ai pris la dernière Raspbian disponible pour faire les builds 1.6.

Il faudrait que je downgrade ?

Ce qui m’“embete” c’est que j’ai installé pas mal de trucs et je ne suis pas sur qu’ils soient compatibles avec la nouvelle distri… :frowning:
et j’aurai à faire cela sur plusieurs Raspberry.
Tu utilises quelle distri?