Pourquoi certains noeuds Cesium+ n'apparaissaient plus dans la liste des noeuds?

J’ai l’impression que les pods césium+ ont du mal à se retrouver entre eux. Quand je suis sur un nœud, il n’y a rien dans la liste des nœuds.

Je penses avoir compris pourquoi peu de Noeud Cesium+ s’affichent dans la liste des noeuds Cesium+ accessibles.

  • @bpresles je penses que ton noeud Duniter est DOWN, non ? Or c’est lui qui avait défini les endpoints Cesium+, et qui les communiquait au réseau. En absence de fiche de pair à jour, le noeud n’est pas connu. Si tu ne veux pas en redémarrer un, alors il faut activer l’option du Pod Cesium+, pour qu’il envoi lui même le endpoint sur le réseau.
  • @fdrubigny Idem : as tu un noeud Duniter HS, par hasard ? Si il est bien accessible peux tu vérifier que /network/peering renvoi les endpoints Cesium+. Si non, il faut que tu les ajoute, via un commande duniter. Redis moi si besoin, et je te retrouverai la ligne de commande exacte.
1 « J'aime »

Mes deux noeuds sont allumés:

  • g1.presles.fr => Noeud calculant et non accessible depuis un client (API désactivée volontairement)
  • g1.cloud-libre.eu => Noeud miroir et accessible depuis un client

Mon noeud Cesium+ est en 1.8.0 et se synchronique sur g1.cloud-libre.eu.
L’option « duniter.enable: false » est en commentaire, donc activée par défaut d’après la documentation de la config.

A noter que l’option duniter.p2p.enable est à true, et d’après la doc ça active aussi duniter.p2p.peering.enable.

De plus l’option duniter.p2p.discovery.enable est à true, l’option duniter.p2p.includes.endpoints est comme suit:

[
   "ES_CORE_API g1.data.e-is.pro 443",
   "ES_USER_API g1.data.e-is.pro 443",
   "ES_SUBSCRIPTION_API g1.data.e-is.pro 443",
   "ES_CORE_API g1.data.adn.life 443",
   "ES_USER_API g1.data.adn.life 443",
   "ES_SUBSCRIPTION_API g1.data.adn.life 443"
]

Ainsi que:

duniter.p2p.peering.targetedApis: [
 "ES_CORE_API"
]

duniter.p2p.peering.publishedApis: [
 "ES_CORE_API", "ES_USER_API", "ES_SUBSCRIPTION_API"
]

Je ne réactiverai pas l’accès à l’API sur g1.presles.fr. Mais vous pouvez utiliser g1.cloud-libre.eu.

Alors, depuis la fameuse MAJ des noeuds Duniter sous Yunohost, ma fiche de peer est accessible ici => https://duniter.adn.life/bma/network/peering mais effectivement elle ne renvoie pas les endpoints Cesium+ …
Effectivement je ne me souviens plus comment les rajouter à ma fiche de peer

Ah merci pour ta réponse.
C’est cette option le problème je penses. La fiche de Pair n’est envoyé qu’au réseau CS+.
Peux tu ajouter à l’option les API : BMAS et
BASIC_MERKLED_API Puis relancer ton Pod stp ?

On va voir si ça règle le soucis

Cf ce post : Installation d'un Pod Cesium+ - #8 par kimamila

Je suppose que c’est « BASIC_MERKLED_API » ?

J’ai modifié comme suit donc:

duniter.p2p.peering.targetedApis: [
 "ES_CORE_API",
 "BMAS",
 "BASIC_MERKLED_API"
]

Ca n’a pas l’air beaucoup mieux :frowning: Tout du moins, si je met Cesium sur g1.data.presles.fr, je vois rien dans la liste des noeuds, par contre si je me met sur g1.data.adn.life, je vois g1.data.presles.fr dans la liste, mais seule.

1 « J'aime »

Salut, j’ai bien rajouté les endpoint CS+ , j’ai redémarré le noeud Duniter, y compris ensuite mon serveur, mais ça ne prend pas la configuration… :frowning:
Je pense qu’il faudrait que je puisse nettoyer les endpoints et les re-configurer peut-être ?